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Ilmajaama ehitamine Arduino ja Raspberry Pi näitel 
http://lingid.ee/ilmajaam 

Koht: HITSA NUTIKLASS  (Akadeemia tee 21/1, Tallinn) https://www.innovatsioonikeskus.ee/et/nutiklass  

Toimumise aeg: 16-17 juuni 2018 kell 9.00-18.00 

Koolitaja ja sisu autor:   Alo Peets  

    alo.peets@ut.ee  

Tartu Ülikooli arvutiteaduse instituut & Robotimeister OÜ 
Rahastaja: Hariduse Infotehnoloogia Sihtasutus (HITSA, Euroopa Liit, Euroopa Sotsiaalfond) 

Koolituse varalised õigused kuuluvad Robotimeister OÜ-le. 

Päevakava 16. juuni 2018 ilmateataja ehitamine Arduino näitel 
 
9.00 Kogunemine, tervitussõnad ja üksteisega tutvumine 

 Nimi 

 Kool 

 Varasem kogemus 

 Ootused 

9.15 Ajurünnak: Mida mõõdab ilmajaam? Millised parameetrid on vajalikud taime kasvamiseks? 
 Kirjutame tahvlile ja teie lehele erinevaid ilma puudutavaid mõisted, suurused ühikud jne… 
9.30. Arduino ülevaade (mis asi? miks kasutada? kust osta? kuidas alustada? jne) 
 Arduino onepagers (materjali lõpus) 

Ametlikud Arduino õpetused: https://www.arduino.cc/en/Tutorial/BuiltInExamples  
10.00 Arduino tarkvaraga tutvus ja esimese tarkvara kirjutamine (LEDi vilgutamine) 
 Arduino IDE (Windows installer) https://www.arduino.cc/en/Main/Software   
 File -> Examples -> Basics -> Blink 

File -> Examples -> Digital -> BlinkWithoutDelay  
Kirjeldame Arduino koodi osasid (Setup, Loop, jne…) 

10.30 Lüliti kasutamine LEDi juhtimiseks (IF lause) 
File -> Examples -> Basics -> DigitalReadSerial 
File -> Examples -> Basics -> Fade 
File -> Examples -> Digital -> Button 

11.00 Serial Monitor, USART & ASCII 
File -> Examples -> Communication -> ASCIITable 
File -> Examples ->Strings 

11.30 Kolmevärviline RGB LED, 3 nuppu 
 File -> Examples -> Communication -> ReadASCIIString  

Serial Monitor parameetrid peavad olema (Newline ja 9600 baud) 
 

  

http://lingid.ee/ilmajaam
https://www.innovatsioonikeskus.ee/et/nutiklass
mailto:alo.peets@ut.ee
http://cs.ut.ee/
https://www.arduino.cc/en/Tutorial/BuiltInExamples
https://www.arduino.cc/en/Main/Software
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12.00 Juhtkangi ühendamine (ADC) & Servo mootori juhtimine (Iteaduino ühendamine vt lk13) 
File -> Examples -> Servo -> Sweep 
File -> Examples -> Servo -> Knob 

 
12.30 Lõuna (omaosalus) 
13.30 Valgustugevuse mõõtmine ja kuvamine 1602 ekraanil 

File -> Examples -> LiquidCrystal -> HelloWorld 
   LiquidCrystal lcd(8, 9, 4, 5, 6, 7);  

 File -> Examples -> Basics -> AnalogReadSerial 

  Muuda koodis A0 -> A1 -> Tools -> Serial Monitor (Serial Plotter) 
Muuda ekraani koodi nii et kuvataks ka valgussensori tulemusi  

14.00 Kaugussensor HC-SR04 
 http://playground.arduino.cc/Code/NewPing  
 Lae alla NewPing teek https://bitbucket.org/teckel12/arduino-new-ping/downloads/  

 Paki lahti ja kopeeri kausta C:\Program Files (x86)\Arduino\libraries\ 

 Taaskäivita Arduino IDE ja File -> Examples -> NewPing -> NewPingExample 

 
  

http://playground.arduino.cc/Code/NewPing
https://bitbucket.org/teckel12/arduino-new-ping/downloads/
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14.30 Arduino WiFi-ga ühendamine ESP8266 
  Arduino IDE -> Tools -> SerialMonitor -> Seadista „Both NL & CR“ ning „115200 baud“ 
  

AT 

 AT+GMR 

 AT+CWMODE? 

 AT+CWMODE=1 

 AT+CWLAP 

 AT+CWJAP=“WiFi SSID nimi“,“WiFiParool“ 

AT+CIFSR 

 
15.30 LCD ekraani kasutamine ja seal andmete kuvamine 
 Lae alla LCD Library https://github.com/JoaoLopesF/SPFD5408  

 Paki lahti ja kopeeri kausta C:\Program Files (x86)\Arduino\libraries\ 

File -> Examples -> SPDF5508_master -> spfd5804_graphicstest 
File -> Examples -> SPDF5508_master -> spfd5804_tftpaint  
Tee muudatused:  

#include <SPFD5408_Adafruit_GFX.h>    // Core graphics library 

#include <SPFD5408_Adafruit_TFTLCD.h> // Hardware-specific library 

#include <SPFD5408_TouchScreen.h> 

 

#define YP A2  // must be an analog pin, use "An" notation! 

#define XM A1  // must be an analog pin, use "An" notation! 

#define YM 6   // can be a digital pin 

#define XP 5   // can be a digital pin 

 

  tft.begin(0x9341); // SDFP5408 

  tft.setRotation(0); 

 
 Kui teljed on vahetuses või pööratud: 
  C:\Program Files (x86)\Arduino\libraries\SPFD5408-master\SPFD5408_TouchScreen.cpp 
  

Asenda rida   return TSPoint(x, 1023-y, z); 

  Reaga    return TSPoint(1023-y, x, z); // for TFT paint 

  
16.30 Kõige eelneva kokku panek ja „Arduino ilmajaama“ ehitamine ning programmeerimine 
 Lae alla „ilmateataja“ kood http://www.ut.ee/~alop/ilmateataja.zip  
 Kaustad „DHT“, „ESP8266“ ja „SPFD5408“ kopeeri kausta  

C:\Program Files (x86)\Arduino\libraries\ 

 
Loe pikemalt kuidas ilmateataja töötab http://comserv.cs.ut.ee/ati_thesis/datasheet.php?id=58265&year=2017  

https://github.com/JoaoLopesF/SPFD5408
http://www.ut.ee/~alop/ilmateataja.zip
http://comserv.cs.ut.ee/ati_thesis/datasheet.php?id=58265&year=2017
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17.30 varuaaeg (ilmateataja korpusesse panek) 
 Lae alla „ilmateataja“ 3D mudel Autodesk Fusion 360 jaoks http://a360.co/2s0HnkP  
 Proovi kõik alamosad korpusesse mahutada. 
18.00 Koolituspäeva lõpp 

 

 

 

  

http://a360.co/2s0HnkP
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Päevakava 17. juuni 2018 Mõõtmistulemuste salvestamine arvutis ja internetis 
 
9.00 Eelmise päeva teadmiste kordamine (vihmaanduri kasutamine) 
 Iseseisev tegevus ja uurimine kuidas kasutada uut andurit 
 http://www.ebay.com/itm/Raindrops-Detection-sensor-modue-rain-module-weather-module-Humidity-
For-Arduino-/400439668701?hash=item5d3c106fdd:g:JtwAAOSw0fhXiFos  
9.30 Gaasi (CO/alkoholi) anduri kasutamine 
 http://eu.banggood.com/Wholesale-Warehouse-9Pcs-MQ2-MQ-3-MQ-4-MQ-5-MQ-6-MQ-7-MQ-8-

MQ-9-MQ-135-Sensor-Module-For-Arduino-wp-Eu-1005800.html 
10.00 õhurõhu mõõtmine BMP280 (UV-valguse andur I2C ja SPI) 

Sketch -> Include Library -> Manage Libraries -> Adafruit BMP280 Library 
Sketch -> Include Library -> Manage Libraries -> Adafruit Unified Sensor (viimane nimekirjas) 

C:\Users\..\Documents\Arduino\libraries\Adafruit_BMP280_library\Adafruit_BMP280.h 

https://learn.adafruit.com/adafruit-bmp280-barometric-pressure-plus-temperature-sensor-breakout  
 

 
11.00 Arduino mõõtmistulemuste salvestamine arvutis. 
 Install Python https://www.python.org/downloads/  

                             Custom install     (NB! pane linnuke Add Python to environment variables) 
 Paigalda pyserial teek C:\ python -m pip install pyserial  

 Näidiskood võta siit http://www.ceda.ac.uk/static/media/uploads/ncas-reading-
2015/logging_data_from_serial_ports_branded.pdf (kõige viimane) 

  #!/usr/bin/env python 

'''Näidiskood mis salvestab mõõtmistulemused arvutisse''' 

from datetime import datetime #Lisame kellaaja funktsionaalsuse 

import serial, io #Sisend/väljund funktsionaalsus 

outfile='serial-temperature3.txt' #väljundfaili nimi 

ser = serial.Serial( # Meetod serial liidese defineerimsieks 

    port='COM7', # Serial liidese number 

    baudrate=9600, # Serial lidiese kiirus 

    timeout=2, 

) 

sio = io.TextIOWrapper( 

    io.BufferedRWPair(ser, ser, 1), 

    encoding='ascii', newline='\r\n' #määrame reavahetuse 

) 

with open(outfile,'a') as f: #lisame faili lõppu 

    while ser.isOpen(): # Kui Serail ühendus on olemas 

        datastring = sio.readline() # Loeme Serail andmed 

        print(datetime.utcnow().isoformat() + '\t' + datastring) 

        f.write(datetime.utcnow().isoformat() + '\t' + datastring) 

        f.flush() #Sunnime vahemälu (cache) sisu kettale kirjutama 

ser.close() 

 

12.00 Lõuna (omaosalus)  

#define BMP280_ADDRESS 0x76 

http://www.ebay.com/itm/Raindrops-Detection-sensor-modue-rain-module-weather-module-Humidity-For-Arduino-/400439668701?hash=item5d3c106fdd:g:JtwAAOSw0fhXiFos
http://www.ebay.com/itm/Raindrops-Detection-sensor-modue-rain-module-weather-module-Humidity-For-Arduino-/400439668701?hash=item5d3c106fdd:g:JtwAAOSw0fhXiFos
http://eu.banggood.com/Wholesale-Warehouse-9Pcs-MQ2-MQ-3-MQ-4-MQ-5-MQ-6-MQ-7-MQ-8-MQ-9-MQ-135-Sensor-Module-For-Arduino-wp-Eu-1005800.html
http://eu.banggood.com/Wholesale-Warehouse-9Pcs-MQ2-MQ-3-MQ-4-MQ-5-MQ-6-MQ-7-MQ-8-MQ-9-MQ-135-Sensor-Module-For-Arduino-wp-Eu-1005800.html
https://learn.adafruit.com/adafruit-bmp280-barometric-pressure-plus-temperature-sensor-breakout
https://www.python.org/downloads/
http://www.ceda.ac.uk/static/media/uploads/ncas-reading-2015/logging_data_from_serial_ports_branded.pdf
http://www.ceda.ac.uk/static/media/uploads/ncas-reading-2015/logging_data_from_serial_ports_branded.pdf
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Raspberry Pi ilmajaam 
http://lingid.ee/raspikoolitus 

13.00 Raspberry Pi tutvustus 

 Raspberry Pi onepager http://www.ut.ee/~alop/onepagers.rar  

 NUTIROBOT http://nutirobot.ut.ee  

13.30 Raspberry Pi tarkvara paigaldus ja seadistamine 

1. Lae alla Raspbian ja järgi juhiseid https://www.raspberrypi.org/downloads/raspbian/ 

2. Kopeeri Raspbian mäukaardile (Ether või Win32DiskImager) 

3. Ühenda hiir, klaviatuur ja HDMI-DVI kaabliga monitor 

4. Preferences -> Raspberry Pi configuration -> System -> vaheta Hostname 

5. Preferences -> Raspberry Pi configuration -> Interfaces -> Enable: Camera, SSH, VNC  

6. Preferences -> Raspberry Pi configuration -> Localisation -> Kõik valikud: Estonian, Tallinn 

7. Raspberry taaskäivitamine 

8. Ühenda Raspberry Pi WiFi-ga (ut_public) 

9. Lae alla Windowsis VNC klient https://www.realvnc.com/raspberrypi/  

10. Ühenda Raspberry Pi-ga kasutades VNC klienti (ava VNC Viewer -> Sisesta Raspberry IP aadress -

> kasutaja: „pi“ parool: „raspberry“) 

11. Lae alla programm Putty https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html  

12. Ühendu Raspberry Pi-ga kasutades SSH ühendust (Putty) 

13. Õpime terminali ja Linuxi käske (vt 

https://courses.cs.ut.ee/MTAT.03.005/2015_fall/uploads/Main/Linux.pdf ) 

14. Failide vahetamine FileZilla https://filezilla-project.org/  

15. Lülita Raspberry Pi välja 

16. Ühenda 7’’ Raspberry Pi originaal monitor ribakaabliga 

17. Ühenda HDMI monitor lahti ja katseta väikest ekraani. 

14.30 Paus 10 min 

  

http://lingid.ee/raspikoolitus
http://www.ut.ee/~alop/onepagers.rar
http://nutirobot.ut.ee/
https://www.raspberrypi.org/downloads/raspbian/
https://www.realvnc.com/raspberrypi/
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
https://courses.cs.ut.ee/MTAT.03.005/2015_fall/uploads/Main/Linux.pdf
https://filezilla-project.org/
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14.40 RaspBerry Pi LEDi vilgutamine 

 

sudo python3 #käivitatakse Python 3 programmeerimiskeskond administraatori õigustes 

import RPi.GPIO as GPIO #  Sisend/väljund viikude paketi  lisamine 

GPIO.setmode(GPIO.BOARD) #  viikude valimine numbrilisel kujul  

GPIO.setup(12, GPIO.OUT) #viik nr 12 väljundiks seadistamine.   

GPIO.output(12,GPIO.HIGH) #viik nr 12 väärtuse kõrgeks seadistamine [LED hakkab põlema]  

GPIO.output(12,GPIO.LOW) #viik nr 12 väärtuse madalaks seadistamine  [LED kustub ära] 

GPIO.output(12,GPIO.HIGH) #viik nr 12 väärtuse kõrgeks seadistamine  [LED hakkab põlema]  

GPIO.output(12,GPIO.LOW) # viik nr 12 väärtuse madalaks seadistamine  [LED kustub ära] 

GPIO.cleanup() # kõikide sisend/väljund viikude seadistuse tühistamine 

exit() #pythonist väljumine 

 

NB! Linuxi käsurida on tõusutundlik  - see tähendab, et on oluline, kas trükitakse suured või väikesed 

tähed. 

 

15.00 Raspberry Pi SenseHat arendusplaadi kasutamine 30 min 

https://www.raspberrypi.org/learning/getting-started-with-the-sense-hat/  

 

15.30 Raspberry Pi kaamera kasutamine 30 min 

https://www.raspberrypi.org/learning/getting-started-with-picamera/  

 

16.00 Raspberry Pi DHT11 anduriga temperatuuri ja niiskuse mõõtmine 

http://lingid.ee/DHT11RASP  

 

 

  

https://www.raspberrypi.org/learning/getting-started-with-the-sense-hat/
https://www.raspberrypi.org/learning/getting-started-with-picamera/
http://lingid.ee/DHT11RASP
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16.30 Raspberry Pi DHT11 anduri andmete sisestamine Google Docsi 

https://learn.adafruit.com/dht-humidity-sensing-on-raspberry-pi-with-gdocs-logging/connecting-to-googles-

docs-updated  

1. Loo GoogleSheet dokument https://docs.google.com/spreadsheet  

2. Loo OAuth2 kasutaja https://developers.google.com/identity/protocols/OAuth2  

3. Anna 1.punktis loodud Google dokumendile …iam.gserviceaccount.com aadressile „edit“ õigused 

4. Kopeeri *.json fail FileZilla abil Raspberry Pi-sse samasse kausta DHT näidiskoodiga 

5. Muuda failis google_spreadsheet.py  

a. DHT_TYPE = Adafruit_DHT.DHT11 

b. DHT_PIN = 4 

c. GDOCS_OAUTH_JSON = ’*.json’ (asenda * oma failinimega) 

d. GDOCS_SPREADSHEETNAME = ’DHT log’ 

6. Käivita mõõtmine „python google_spreadsheet.py“ 

 
17.00 Koolituse kokkuvõtmine. 

 Kuidas edasi … 

Ehita „päris“ ilmajaam www.instructables.com/id/Build-a-Raspberry-Pi-SUPER-Weather-Station/  

„Päris“ ilmajaama operatsioonisüsteem Raspberry Pi-le http://www.weewx.com/  

Tõravere ilmajaam Weewx tarkvaral http://hermes.aai.ee/weewx/ 

Loe ja uuri TÜ Arvutiteaduse instituudi lõputöid http://comserv.cs.ut.ee/ati_thesis/  

17.30 Koolituse lõpp 

  

https://learn.adafruit.com/dht-humidity-sensing-on-raspberry-pi-with-gdocs-logging/connecting-to-googles-docs-updated
https://learn.adafruit.com/dht-humidity-sensing-on-raspberry-pi-with-gdocs-logging/connecting-to-googles-docs-updated
https://docs.google.com/spreadsheet
https://developers.google.com/identity/protocols/OAuth2
http://www.instructables.com/id/Build-a-Raspberry-Pi-SUPER-Weather-Station/
http://www.weewx.com/
http://hermes.aai.ee/weewx/
http://comserv.cs.ut.ee/ati_thesis/
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Raspberry Pi 3 
Kõige levinum ja populaarseim miniarvuti. 

 Operatsioonisüsteem: Raspian (modifitseeritud Debian Linux) 

 Protsessor: 1.2GHz 64-bit quad-core ARMv8 CPU (Pi3) 

 Muutmälu 1 GB RAM, uSD kaardil operatsioonisüsteem ja kasutaja 

failid 

 Sisend-väljund : 40 digitaalset I/O viiku (NO ADC) 

HDMI, 10/100 Ethernet, 4x USB 2.0, sissehitatud 

b/g/n WiFi ja bluetooth 4.1 LE 

 Tööpinge: 3,3V  

 Väline toide: 5V (ideaalne kasutamaks akupangaga) 

 Mõõtmed: 85 x 56 x 17 mm 

 Plussid: suhteliselt odav „päris“ arvuti kuhu saad ühendada 

 hiire,klaviatuuri ja monitori, head eestikeelsed õpetused ja 

juhendid saadaval, palju laiendusplaate ja andureid, jooksutab 

„päris“ Linuxi 

 Puudused: Hind, ei saa ühendada analoogandureid, voolutarve, 

lisavarustuse vajadus (2A 5V laadija, uSD kaart, HDMI-DVI 

kaabel jne..) 

 Hind: ~40 EUR originaal 
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Arduino / Genuino UNO 
 

Kõige levinum ja populaarseim elektroonika ja mikroprotsessori 

programmeerimisega alustamiseks sobiv arendusplaat. 

 Programmeerimiskeskkond: Arduino IDE (C-keel) 

 Vaba tarkvara ja vaba riistvara (kogu tarkvara, skeemid jne on 

avalikud) 

 Protsessor: ATmega328P (16MHz, 8 bit, 32 KB, AVR) 

 Sisend-väljund : 14 digitaalset I/O viiku (millest 6 PWM) 

   6 Analoog sisendit 

 Tööpinge: 5V või 3,3V  

 Väline toide: 6-20V (ideaalne 6LR61 9V, nn. korona patareiga) 

 Mõõtmed: 68.6 mm x 53.4 mm  

 Plussid: Odav, head eestikeelsed õpetused ja juhendid saadaval,  

palju laiendusplaate ja andureid, ei vaja eraldi programmeerijat 

 Puudused: aeglane, vähe programmimälu, suur, piiratud USB 

funktsionaalsus, wifi ja bluetooth puudub. 

 Hind: 20 EUR originaal (kloonid alates 3 EUR-ist)  
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Arduino ja teised TÜ ATI juhendid ...  https://courses.cs.ut.ee/kids    

https://courses.cs.ut.ee/kids
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