Using Microsoft Word 2007/2010
for Writing Technical Documents

Valter Kiisk
Institute of Physics, University of Tartu

Last update: May 1, 2017
ABSTRACT

This writing collects some non-trivial information about the preparation of longer technical documents in Microsoft Word (version 2007/2010). It’s addressed mainly to people preparing scientific papers, dissertations, technical manuals and other documents of similar nature and complexity. While exposing mainly tools suitable for quick preparation of short documents, it actually does have a number of features for handling longer, structured documents containing lots of figures, formulas, bibliography and cross-references. Thorough textbooks frequently suffer from overly detailed or formal descriptions where the ideas are dissolved. Since the present document itself also follows the ideas to be discussed, this *.docx file could possibly serve as a template for certain tasks.

NOTATION AND WORD 2007/2010 USER INTERFACE

Starting with Word 2007, Microsoft dropped the classical user interface (UI) design based on menus and toolbars. The so-called “Ribbon” is an attempt to unify these two UI concepts. The Ribbon consists of tabs, and each tab contains one big, two-dimensional sectioned toolbar containing controls like buttons, lists, drop-down menus etc. Controls on each tab are logically grouped, with the group name shown below the controls. Many groups contain only the most frequently needed controls whereas the corresponding dialog box or task pane with all available options (Font, Page Setup, Paragraph, Styles, etc.) appears after clicking the small arrow-like button located to the right of the group name. Most tabs are static but there are also a number of contextual tabs. For example, if the cursor is inside a table, tabs Design and Layout become visible (grouped under the name Table Tools). Double-clicking any tab hides the Ribbon, leaving nearly full screen for the document. The Ribbon is relatively dynamical entity — the appearance and layout of the controls depends on the size of the Word window [1].

In this document a notation like Home › Paragraph generally implies to open the Paragraph dialog box from the Home tab, but it may also refer to the Paragraph group on the Home tab. So the writing Home › Paragraph › Indents and Spacing means to open the Paragraph dialog and select the Indents and Spacing sheet whereas Home › Paragraph › Multilevel List › Define New List Style means to click on the button "Define New List Style" located in the Home › Paragraph group and then select the command Define New List Style from the drop-down menu.

Figure 1-1. The structure of the Word 2007/2010 Ribbon.
Figure 1-1. The structure of the Word 2007/2010 Ribbon .................................................. II
Figure 2-1. The Styles task pane. ................................................................................. 4
Figure 2-2. Controlling the spacing between paragraphs ............................................. 5
Figure 2-3. Paragraph’s pagination properties ................................................................ 5
Figure 3-1: Field insertion/editing dialog ....................................................................... 7
Figure 4-1: Customization dialog of multilevel list ......................................................... 9
Figure 5-1: Calculating the factorial of N. The diagram is drawn on a drawing canvas by using the drawing tools provided by Word ......................................................... 12
Figure 5-2: Photo of Earth by Suomi NPP satellite ......................................................... 13
Figure 5-3: Photo of Earth by Apollo 17 .......................................................................... 13
Figure 8-1: The Find and Replace dialog ...................................................................... 19
Figure 8-2: The dialog for setting up a table of contents .............................................. 20
Figure A-1: The Reveal Formatting task pane ............................................................... 26
CHAPTER 1. INTRODUCTION

1.1. An overview of word processing and related topics

In the era of typewriters, the typist himself was responsible for imposing proper line and page breaks in the flow of text. In addition, he had to employ multiple spaces and carriage returns to attain desired alignment and spacing of the text. When using a word processor, however, the author is just expected to indicate how the text is structured (split into words, sentences, paragraphs, chapters and so on). The software is responsible for text wrapping and pagination, i.e. breaking the text into lines and pages. Furthermore, differently from a plain text editor (like Notepad) a text processor is usually capable of achieving a pleasing typesetting at full justification (like the current paragraph) by properly adjusting word spacing and finding proper hyphenation points. The author can influence the typesetting through the formatting rules but he should not try to directly control each line and page break. The natural wrapping of text onto a new line is called a soft line break.

Typesetting software comes in two flavors: it may be either WYSIWYG (What You See Is What You Get) or markup-based. In the former case the look of the editable document on the computer screen is nearly identical to the printout, i.e. the typesetting takes place in real time as the text is keyed in. In the latter case, however, the content is typed in a plain text editor (say, Notepad) and special textual codes are inserted within the content to designate the logical structure and formatting of the document. This text file is then fed to a typesetting engine in order to actually typeset the document. Well-known markup languages are \LaTeX{} and HTML. A WYSIWYG software possibly also utilizes some markup behind the scenes, but the user is generally not supposed to deal with that.\footnote{A good example is Adobe Dreamweaver, a WYSIWYG frontend to HTML and other web technologies.} The two main problems with WYSIWYG text processing seem to be that (1) the software must sacrifice some quality for the speed, and (2) it is too easy for an incompetent user to mess up the formatting of the document. On the other hand, the markup-based systems are fairly inefficient (unproductive) in preparing short sophisticated layouts such as newspapers, magazines, posters, flyers, etc.

Many heavier WYSIWYG programs (incl. text processing and CAD software) permit simplified (drafting) views. Only in the Print Layout view (View ➤ Document Views) Word tries to achieve maximally WYSIWYG display whereas the simplified Draft view is suggested for routine editing of body text. The Draft view does not display page borders, header/footer areas, floating graphics and other visuals possibly distracting attention of the author. Other than that there is probably no reason to prefer the Draft view as the computational overhead of the Print Layout view is insignificant for a typical PC nowadays.

There are actually two greatly overlapping kinds of WYSIWYG software: word processors and desktop publishers. Traditionally, word processing software is primarily meant for composing documents (i.e. editing and formatting text) whereas desktop publishing software is intended to finish those documents (i.e. combining the text with accompanying graphics and performing professional typesetting). However, the distinction is getting increasingly more blurred. Yet, it is usually ill-advised to use a typical word processor for creating either short massively sophisticated layouts or extremely long, highly structured documents. Also, due to the lack of fine spacing and kerning capabilities a word processor is usually unable to produce the quality typesetting (at full justification) typical to desktop publishers (although for most people it might be hard to notice the difference \footnote{A good example is Adobe Dreamweaver, a WYSIWYG frontend to HTML and other web technologies.}). Well-known word processors are MS
Word and OpenOffice.org which though incorporate quite many features of desktop publishers. Examples of high-end desktop publishers are Adobe InDesign and QuarkXPress which are geared towards layout-intensive work. Finally, there are programs like Adobe FrameMaker and Corel Ventura which are suitable for creating long structured technical documents but are quite inconvenient for short and quick designs. MS Office suite includes also an entry-level desktop publishing application called MS Publisher.

If one is going to prepare a lengthy document containing lots of mathematics and lots of floating graphics, he may need to consider LaTeX as an alternative to WYSIWYG systems [3]. Additionally, a casual user is almost incapable of preparing wrongly formatted document in LaTeX. On the other hand, unless a good template is provided (by a publisher, university, etc.) the detailed control of the formatting of LaTeX-based documents requires a fair amount of technical information. There exist some more-or-less WYSIWYG front-ends for LaTeX (Scientific Word, LyX) but their effectiveness is arguable.

When a document has been composed and finished in a word processing or publishing software, it is then usually converted to a file format (such as PDF, PostScript or XPS) that is convenient for electronic distribution, printing, viewing on computer screen, or archiving. Such file format is just supposed to preserve the complete description of a fixed-layout document and is not meant for further editing (though minor changes and annotating/commenting might be possible). Those file formats have freeware viewers available for most platforms.

### 1.2. Basic rules of text editing in Word

Pressing **ENTER** implies a paragraph break in Word and is not meant for adding space between paragraphs. So press **ENTER** just once to start new paragraph. Similarly, multiple spaces are not meant to provide horizontal spacing. Paragraphs have special attributes to control the alignment and spacing (Home > Paragraph). Special alignment of text is achieved by setting proper tab stops (Home > Paragraph > Tabs) or using tables (possibly with non-visible borders).

If it is necessary to insert new line within a paragraph, use manual line break (**SHIFT**+**ENTER**). For example, URLs and filenames tend to be so long that you may want to move them entirely to a separate line. Note that if the paragraph is justified then the line preceding the manual line break is going to have large gaps between the words. To switch off such behavior, enable the option File > Options > Advanced > Layout options > Don’t expand character spaces on a line that ends with SHIFT-RETURN.

If it is necessary to eliminate the possibility of soft line break between words, use non-breaking space (**CTRL**+**SHIFT**+**SPACE**) instead of ordinary space to separate the words. For example, non-breaking space is sensible when separating the numerical value and the unit of a quantity (say, 30.48 cm). Similarly, there is a non-breaking hyphen (**CTRL**+[-]) that prevents breaking a line at the hyphen. For example, phone numbers (5578-3010), model numbers (Core i7-860) or words such as CD-ROM should never be broken.

Do not use ordinary hyphen (-) to force custom hyphenation of words. Instead, the optional hyphen (**CTRL**+[-]) hyphenates the word only if necessary while remaining invisible otherwise. Optional hyphens are also inserted during the manual hyphenation of document (Page Layout > Page Setup > Hyphenation > Manual).

As an aid for editing, it is sometimes useful to switch on the display of non-visible (formatting) characters by pressing the button located in the Home > Paragraph group. Each type of non-visible character has distinct display as shown in the table. The display of

<table>
<thead>
<tr>
<th>Character</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ordinary space</td>
<td><img src="image" alt="ordinary space" /></td>
</tr>
<tr>
<td>non-breaking space</td>
<td><img src="image" alt="non-breaking space" /></td>
</tr>
<tr>
<td>paragraph break</td>
<td><img src="image" alt="paragraph break" /></td>
</tr>
<tr>
<td>manual line break</td>
<td><img src="image" alt="manual line break" /></td>
</tr>
<tr>
<td>optional hyphen</td>
<td><img src="image" alt="optional hyphen" /></td>
</tr>
<tr>
<td>tab</td>
<td><img src="image" alt="tab" /></td>
</tr>
</tbody>
</table>
these characters is mainly useful for troubleshooting purposes, otherwise they are just distracting attention.
CHAPTER 2. STYLES

2.1. The idea of styles

The concept of style provides the preferred means to achieve consistency in formatting. Technically, a style is a named set of formatting attributes that can be linked to a paragraph (paragraph style) or individual characters (character style). Styles accommodate font, indents, spacing, pagination, language used for spell-checking and hyphenation, bullets & numbering, tab stops, borders & shading. The main benefits of using styles follow from the fact that a style is stored separately from the formatted text so that whenever the style is modified, all linked paragraphs or characters update their look accordingly (unless overridden by direct formatting). Therefore, styles provide a way to separate the content of a document from the formatting (look), so that the author can just concentrate on writing, and control the formatting of the whole document centrally as needed. In addition, the use of styles imposes a discipline in the structuring of the document (i.e. dividing the document into chapters and other logical subdivisions down to individual paragraphs of body text). For example, one possible route of starting the preparation of a new lengthy document is to first set up the hierarchical structure of the document (using the heading styles) and thereafter fill in the content [4]. There is a special Outline View for setting up and restructuring a document (View ▶ Document Views).

Thus, all repeating elements of similar formatting (headings, body text paragraphs, figure captions, displayed equations, etc.) should be linked to common style, and thereafter, all formatting of these text elements should be carried out through the modification of the style (i.e. by avoiding the direct formatting options from the Home tab). For example, in this document all figure captions are linked to a special paragraph style whereas all commands and shortcut keys adhere to a special character style making it easy to centrally manage their look. On the other hand, it is rather meaningless to use styles to control the formatting of the title page, which appears just once in the document (unless it is desired to coordinate the fonts and colors of the title page with the rest of the document).

Home ▶ Styles task pane (Fig. 2-1) is the central place to apply and manage paragraph and character styles in MS Word. Word 2007/2010 contains also the Quick Style Gallery to allow quick selection of the most frequent styles directly from the Home tab. Styles can be added to the Quick Style Gallery from the Styles task pane.

Finally, we note that there exist also table styles and list styles. A table style allows applying special formatting (shading, font, border thickness, etc.) either to the whole table or just the special parts of the table (such as header row, first column, odd/even row etc.). Although this feature is not considered very mature, it may have some useful effect when a document contains many similar and relatively simple tables. A list style is required to implement automatic multilevel lists (see Chapter 4).
2.2. Further possibilities to utilize styles

- As mentioned already, never use blank lines to control the spacing between successive paragraphs of body text or the spacing reserved before and after headings. Every paragraph has corresponding spacing attributes (Fig. 2-2) which are also defined as part of the paragraph style.
- For the same reason never press TAB to indent the first line of body text paragraph because in the future you may want to modify the amount of the indentation or disable it altogether in favor of an additional spacing between successive paragraphs. Modifying the style will fix the problem throughout the document at once.
- It is not necessary to type, for example, chapter title directly in capital letters. This behavior should be the property of the style (check All caps in style’s font settings). Similar caution is appropriate for other possible transformations of the font, like SMALL CAPS, shadow, color, etc.
- Quite commonly, the author wishes to emphasize some terms or phrases in his document. However, it may not be clear in advance whether the italic, bold or underline formatting (or some more exotic decoration) will be the most delicate way to catch the attention of the reader. Therefore, a dedicated character style is necessary. One can employ the built-in styles EMPHASIS or STRONG (they default to italic and bold).
- Instead of defining your own styles from scratch when starting a new document, it’s most efficient and reliable to employ the built-in BODY TEXT style for body text* and the built-in heading styles (HEADING 1, HEADING 2, etc.) for headings. There are a bunch of good reasons to stick to the built-in heading styles [5]. By default, they are already properly included in the table of contents and have convenient shortcut keys assigned. They are also needed for implementing certain numbering schemes as mentioned in section 5.3.
- In addition to the Draft and Print Layout views, Word has the Outline view displaying a collapsible and rearrangeable document structure based on the applied heading styles. This feature comes handy during the designing and restructuring of a long document.
- Styles can be hierarchical (cascading): a new style can be based on an existing style. If you do not override a property of the new style, it’s inherited from the base style. Character styles are based on the default paragraph font. For example, the character style STRONG only adds the boldface font style to the underlying paragraph font.
- There is no need for a manual page break to start every chapter on a new page. The corresponding heading style can accommodate this behavior. Paragraph styles have also a handful

---

* Note that NORMAL is active by default (instead of BODY TEXT) when starting a new document and is therefore frequently employed for the body text. This is usually fine except that it won’t let modifying the body text without possibly affecting most of the other styles since the NORMAL style is meant to serve as the base of all paragraph styles [6].
of other useful settings for controlling the pagination of paragraph (Fig. 2-3). For instance, heading styles usually have Keep with next checked preventing them remaining at the end of page alone.

- If a paragraph has incidentally lost its style-specified indents, spacing or alignment, move the cursor into the paragraph and reset the paragraph (CTRL+R). If you have applied direct formatting (or a character style) to a piece of text, you can restore the formatting in accordance to its paragraph style by selecting the text and resetting the characters (CTRL+SPACE).
CHAPTER 3. FIELDS

3.1. The idea of fields

A field is a placeholder that contains special instructions to “calculate” the content to display. A field is used to display a piece of text that might change from time to time and needs to be automatically updated. Word itself uses fields for displaying and updating the page numbers, the table of contents, etc. As an additional example, the date the document was last saved as shown on the title page of this document is produced by a special field. In order to create a field, you may use either the Insert ▶ Text ▶ Quick Parts ▶ Field command to browse the list of all available field types (Fig. 3-1) or just insert a blank field placeholder (CTRL+F9) and type the proper field codes between the curly braces (then select Update field from context menu to evaluate the code). For example, the field code that produces the current page number (in header or footer) looks like \{ PAGE \}. The context menu of a field contains also command Toggle Field Codes to switch the placeholder between the evaluation result and the field definition code.

Field codes employ usually various switches to modify their behavior. These switches can be written directly as part of the field code or conveniently picked from the Field dialog. Note that most fields accept \* MERGEFORMAT switch to preserve, during updates, any direct formatting that has been applied to the field result (the switch is represented by the Preserve formatting during updates checkbox in Fig. 3-1).

Although fields are supposed to produce dynamical output, most fields do not update automatically. In order to ensure that all fields in the document reflect the latest changes, select all text (CTRL+A) and press F9. In the case of the table of contents (or the table of figures, etc.), Word asks if only the page numbers or the whole table needs an update. In the File ▶ Options dialog (sheet Display) it is also possible to check Update fields before printing.

If you’re going to distribute or submit your Word document (to a publisher, for example) it might be advisable to remove all fields and replace them with the most recent evaluation results as static text by using the Unlink fields command (CTRL+SHIFT+F9). In order to distinguish fields from static text, you may want to make a proper selection for Field shading in the Advanced sheet of File ▶ Options dialog.
### 3.2. List of some useful fields

<table>
<thead>
<tr>
<th>Field code</th>
<th>The purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{PAGE}</code></td>
<td>Displays the current page number. The field is created, for example, by the command Insert ▶ Header &amp; Footer ▶ Page Number.</td>
</tr>
<tr>
<td><code>{NUMPAGES}</code></td>
<td>Displays the total number of pages in the document or current section. They can be used in combination with <code>{PAGE}</code> to implement the “Page X of Y” style page numbering.</td>
</tr>
<tr>
<td><code>{SECTIONPAGES}</code></td>
<td></td>
</tr>
<tr>
<td><code>{SEQ sequence}</code></td>
<td>Displays the next element of a numeric sequence labeled “sequence”. The sequence starts with number 1 and is incremented by 1 each time. For example, it can be used to automatically number figures, tables and equations as <code>{SEQ Figure}</code>, <code>{SEQ Table}</code>, <code>{SEQ Equation}</code>.</td>
</tr>
<tr>
<td><code>{SAVEDATE}</code></td>
<td>Displays the date the document was last saved.</td>
</tr>
<tr>
<td><code>{REF bookmark}</code></td>
<td>Inserts the text represented by the bookmark labeled “bookmark”. The Insert ▶ Links ▶ Cross-reference command relies on this field.</td>
</tr>
<tr>
<td><code>{STYLEREF stylename}</code></td>
<td>Displays the most recent paragraph text or paragraph number which was formatted with the style “stylename”. It can be used to display running headings, etc.</td>
</tr>
</tbody>
</table>
4.1. The idea of automatic multilevel lists

A technical document frequently requires the use of multilevel lists, such as in the following example:

1. Text processing software
   1.1. Microsoft Word
   1.2. Corel WordPerfect
   1.3. Sun StarOffice
   1.4. OpenOffice.org
2. Desktop publishing software
   2.1. Software for short sophisticated layouts
       2.1.1. Adobe InDesign
       2.1.2. Quark XPress
   2.2. Software for long structured documents
       2.2.1. Adobe FrameMaker
       2.2.2. Corel Ventura
       2.2.3. LaTeX

The trivial advantage of using automatic bulleted or numbered list is that it will be very convenient to insert and delete items any time with instant automatic renumbering. Even more importantly, it is possible to centrally manage the bullet type or numbering scheme (Arabic, alphabetic, Roman, etc.), the indentation of list levels, etc.

4.2. Implementation in Word

In Microsoft Word, lists are created by the combined action of paragraph styles and list styles. List styles determine the bullet type/numbering scheme and the indentation of the different list levels whereas paragraph styles take care of the remaining attributes such as font size and vertical spacing.

To start creating a new list style, execute Home ▶ Paragraph ▶ Multilevel List ▶ Define New List Style (or select New Style from the Styles task pane and set Style type to List). Then click Format ▶ Numbering (up to this point it doesn’t matter if this is to be a bulleted or numbered list). As a result, a fairly sophisticated dialog is opened (be sure to click the More button on the dialog to see all settings as shown in Fig. 4-1). This dialog is used to define bullet/number schemes and alignment for each list level. Active list level is selected from the list box near the top left corner. The numbering scheme is composed in the text box labeled Enter formatting for this level. In addition to the

![Figure 4-1: Customization dialog of multilevel list.](image)
counter values (selected with the two combos titled Number style and Include level number from), you are allowed to type custom text into the text box (e.g., to include dashes, periods, brackets, etc. in the level number). Also, for each sublevel tick the Restart list after check box near lower right corner and ensure that the corresponding combo box displays the correct parent level.

The settings in the Position section determine the distance (Aligned at text box) of the left edge, center, or right edge of the list number from the page/column margin. The indent of the text following the number is determined by the measure in the Text indent at text box. Note that you shouldn’t try controlling these indents afterwards by modifying the paragraph format of the style.

The final decision is about the linking of the different list levels with corresponding paragraph styles. If this linking is not made, Word assumes the default LIST PARAGRAPH style for each paragraph to which the list style is applied (independently of the list level). However, Word also contains five built-in styles for bulleted lists (from LIST BULLET to LIST BULLET 5) and numbered lists (from LIST NUMBER to LIST NUMBER 5). These can be linked with different list levels.

Now, to actually create a multilevel list, the list style must be applied to a paragraph which thereafter becomes a top-level list item. Pressing ENTER creates the following list item at the same list level as the current one. While the cursor is placed immediately after the item number, pressing TAB moves the item one level down (increases indent) whereas SHIFT + TAB does the opposite.

Multilevel numbering of headings is set up essentially in the same manner as that of a body text list, one just needs to link each list level to the corresponding heading style (Link level to style combo box in Fig. 4-1). Depending on the document, you may want to include the words “Chapter”, “Section”, “Appendix”, etc. in the number of a title. In this case you need to type this word into the Enter formatting for number text box.

By default, all paragraphs with the same numbering style are supposed to belong to the same list and are numbered continuously throughout the document. To start a new list employing the same list style, right-click on the number of the first paragraph of the new list and select Restart at 1 from the context menu. Note that there is also a Continue Numbering command available (which should have the same effect as resetting the paragraph with CTRL + B).
CHAPTER 5. FIGURES

5.1. Preparing figures for Word

Using of figures with Word involves a number of steps, such as creating, placing into Word document, captioning, layout, numbering and cross-referencing. Usually it’s best to prepare high-quality graphics in dedicated software other than MS Word. From the image-editing program you need to save or export the image in a format that Word can later import. Photographs are best saved in JPEG format whereas vector graphics should be stored as EMF (Enhanced Metafile) which is a native vector format of Windows (and MS Office). Unless anti-aliasing is used, JPEG is not recommended for vector graphics and technical drawings because at higher compressions the JPEG algorithm introduces artifacts whenever sharp transitions are present in the image. If EMF cannot be used for some reason, one can alternatively employ a lossless raster format such as PNG and GIF which provide a good compression and wide support (GIF is limited to only 255 colors, however). Professional bitmap file format is TIFF, which has more storage options but is therefore also more complicated to handle. In order to export optimum-resolution bitmap graphics from any external graphics software, it is most convenient not to deal directly with the number of pixels, but to indicate (1) the real planned size of the image (in cm) in the final document, and (2) the required printing or display density of the document (dots per inch or DPI). Usually 300 DPI is adequate even for printing purposes.

It is usually preferred (at least for large photos) to insert the image from a file, instead of pasting from the clipboard, because in the former case Word can maintain the original compression whereas in the latter case Word cannot know the optimal compression to apply (so it applies lossless PNG internally). Never copy and paste large photos (e.g. maximum resolution images from a digital camera) leading to bloating file size; use dedicated software (like IrfanView [7]) to prepare a properly cropped, downscaled and compressed JPEG file. However, if an image is already inside the Word document, then making a duplicate of that image practically does not increase the file size because Word considers the two images as the same [8]. This even works if you crop the image (Format ▶ Size ▶ Crop) since visible area is just a viewport for the underlying original image.

Word is actually able to apply a downsampling to images (Format ▶ Adjust ▶ Compress Pictures). However, the resolution options only go up to 220 DPI. Moreover, Word tends to apply certain downsampling to new or modified images even automatically when saving the document. This can too much degrade image quality, especially if an image will be resized several times. To avoid this, enable the option File ▶ Options ▶ Advanced ▶ Image Size and Quality ▶ Do not compress images in file. To reduce the Word document size, enable also the option Discard editing data. In this case the image operations such as cropping, color/brightness/contrast corrections or artistic effects cannot be undone. However, note that if an inserted photo is cropped inside Word and the cropped areas are afterwards deleted (using Format ▶ Adjust ▶ Compress Pictures ▶ Delete cropped areas of pictures), the file size may actually increase because Word now has to create a new image and cannot maintain the original compression [8].

Frequently the source of an image is a document in PDF format. Use the Snapshot tool of the PDF reader to copy a screen area as raster image into clipboard and use IrfanView or any other photo editor to save a properly cropped image. The resolution of the copied image is determined by the resolution of the monitor and the size of the selection rectangle in the PDF viewer. In documents related to computing, screenshots of some software are frequently

11
incorporated. Press \texttt{ALT+PRINT SCR} to capture the image of active window or dialog box into clipboard (\texttt{PRINT SCR} alone captures the whole desktop). For more specialized tasks, use a screen capture utility like MWSnap [9]. Word 2010 includes also a basic screenshot tool (Insert \ Illustrations \ Screenshot).

The drawing tools provided by Word are sometimes sufficient for creating simple technical schemes and diagrams. Word also provides a special drawing canvas (Insert \ Illustrations \ Shapes \ New Drawing Canvas) which keeps the drawing primitives (lines, shapes, textboxes, etc.) together and provides a boundary between the drawing and the surrounding paragraph text (Fig. 5-1).

\textbf{5.2. Positioning and captioning figures}

Follow these steps to create a figure with caption in a Word document:

1. Position the cursor into an empty paragraph.
2. Put an inline image into the paragraph. Insert the image from a file (Insert \ Illustrations \ Picture), paste from the clipboard (Home \ Clipboard \ Paste), or create a drawing canvas (Insert \ Illustrations \ Shapes \ New Drawing Canvas) and draw a diagram using the drawing tools provided by Word.
3. If a drawing canvas was used, you can draw a textbox (Insert \ Illustrations \ Shapes \ Text Box) containing the caption directly on the drawing canvas. Otherwise, press \texttt{ENTER} to create a new paragraph beneath the image and type a caption for the figure.
4. Apply a special paragraph style to the caption to grant the possibility of creating the list of figures if needed (see page IV as an example) and centrally control the format of figure captions in the future. There is a built-in style \texttt{CAPTION} which is meant for the purpose (note that the numbering procedure, described in the next section, automatically applies this style).
5. If you don’t need that the text freely flows past the figure (as it does in professional layouts), then all you need to do is to click on the figure, open Home \ Paragraph \ Line and Page Breaks dialog and check Keep with next. That ensures that the paragraph containing the figure stays always on the same page as the following paragraph holding the caption (for convenience, you may define for figures a special style enforcing this property). In addition, the style of the figure caption should have Keep lines together checked in paragraph settings to avoid breaking the caption across pages.
6. However, if you would like to create a floating image (like Fig. 5-1), select the image along with its caption and select Insert \ Text \ Text Box \ Draw Text Box. This operation encloses the figure and its caption inside a textbox (in previous versions of Word, a frame was used for this purpose [10]). Resize the text box as necessary. Click on the border of the text box and select Format \ Arrange \ Wrap Text \ Square. Right-click the text box, select More Layout Options and set the horizontal and the vertical position as necessary. Usually you want the figure to align horizontally to the left or right margin and vertically to the top or bottom margin. It also possible to align the figure vertically relative to the paragraph the

![Figure 5-1: Calculating the factorial of N. The diagram is drawn on a drawing canvas by using the drawing tools provided by Word.](image-url)
By default, the anchor will jump to the nearest paragraph when you reposition a graphical object. Check Lock Anchor to make the image stay linked to (and stay on the same page as) the paragraph with which it is currently associated. Check Move with Text to make the figure move with the paragraph it is anchored to. You can anchor the text box to a different paragraph by dragging the anchor symbol in front of the paragraph (if the anchor is not visible, you must check the option File ▶ Options ▶ Display ▶ Object Anchors).

For space-conserving and aesthetical reasons one may want to setup multiple figures side-by-side or one above the other. For that purpose (and also as an alternative to the use text boxes) it is possible to use a table reserving a cell for each figure with its caption. Note that breaking the table row across pages should not be allowed in this case (Table Properties ▶ Row).

5.3. Numbering and referencing figures

Automatically numbered captions for figures and tables are created with the References ▶ Insert Caption dialog. Unsurprisingly, the number produced by the command turns out to be a SEQ field, for example { SEQ Figure } or { SEQ Table } or { SEQ Equation } depending on the label selected. This field produces a sequence of integral numbers as mentioned in section 3.2. Furthermore, in the Caption dialog (click button Numbering) one can insist that the current chapter number be included as the prefix. This is the style sometimes used in longer structured documents (see figure captions of the present document as an example). That composite number is produced by the combination of two fields as follows: { STYLEREF 1’s }- { SEQ Figure ’s 1 }. The STYLEREF field is producing the number of the most recent level 1 title (i.e., HEADING 1). The switch \s in the field causes the field to display only the number of the heading without any text (like Chapter or Appendix) that might also be defined as part of the numbering. The \s 1 code in the SEQ field forces the restart of numbering whenever the level 1 style (e.g. HEADING 1) is encountered. Altogether, this algorithm produces figure numbers similar to those used in this document. Note that inserting figure captions in this way also conveniently applies built-in CAPTION style to the paragraph. In order to produce the above combination of fields manually, one can easily prepare a corresponding macro (see Appendix B).

MS Word provides the References ▶ Captions ▶ Cross-reference command for creating a cross-reference to various parts of the document. However, the referencing capability appears to have a serious limitation: referencing the number only is not possible (for example, you are forced to say “see Figure 3” instead of “see Fig. 3”). Fortunately, the limitation is easy to

---

* You can also insist the horizontal or vertical position be just inside margins, but Word might not be smart enough to make reasonable decisions on the placement of figures. As far as I can tell, there is no possibility to achieve such robust figure/table positioning behavior available in LaTeX.
overcome by placing a bookmark enclosing the text to be referenced. * Mark the figure number, select Insert ▶ Links ▶ Bookmark and give the bookmark a unique and meaningful name (to make it easy to recognize later). Then go to the point in the document where the reference have to appear, click References ▶ Captions ▶ Cross-reference, select Bookmark from Reference type, select Bookmark text from Insert reference to, and finally select the name of the bookmark. It is beneficial to check Insert as hyperlink making it easy to navigate the document. You may ascertain that this procedure actually creates a REF field. This field accepts the switch \h to behave as hyperlink.

Note that after placing the bookmark you must be careful in the modification of the text nearby. If you insert some text just before or just after the bookmark you won’t know if it becomes enclosed within the bookmark or not. If things go wrong you just have to redefine the bookmark (with the same name).

* The existing functionality is also based on bookmarks but these bookmarks are hidden and not meant to be controlled by the user. These hidden bookmarks usually enclose both the label and the number making it impossible to reference the number alone.
CHAPTER 6. EQUATIONS

6.1. The style of equations

Handling of math in Word involves a number of problems: how to create, align, number and reference equations, and what formatting style is appropriate to use. The style used for writing equations is somewhat a matter of personal taste and traditions of the scientific discipline the writer is representing. Still, professional publications adhere to some widely accepted math and physics traditions which are supposed to improve the aesthetics and readability of the text.

- Font size should match the surrounding paragraph text.
- Alphabatical symbols denoting mathematical variables, physical quantities, etc. are set in italics (x, y, a, β). Capital Greek letters are an exception being usually written in upright (Φ, Δ).
- Numbers and normal text (including textual subscripts) are in upright letters. This applies also to units of physical quantities, symbols of chemical elements, symbols of elementary particles, etc. Example: \( V_{rocket} = 8000 \text{ m/s} \) (note that there is a space between the numerical value and the unit).
- Function names (sin, log, …) and mathematical operators (summation and integral signs, etc.) are set in upright letters.
- Multiplication symbol (· or ×) is used only in some special cases, for example when denoting numbers in scientific notation (e.g. 1.98×10²⁴). In equations it is usually omitted. The asterisk symbol (*) is meant to serve only in programming languages (see Fig. 5-1 for an example) and not in traditional math notation. The same applies to symbols like \( \geq, \leq, \text{ and } \neq \).
- The hyphen (-) is not the minus sign (−) and looks uneesthetic in this role. The minus sign is usually designed to be the same length and at the same height as the plus and equals signs. En-dash looks better as a minus sign, but Unicode fonts include also a special Minus Sign character in the Mathematical Operators subset (Insert \( \text{Symbol} \)).
- The brackets are set in upright font. The size of brackets should match the enclosed content (equation editors have usually special vertically “stretching” brackets for that purpose).
- Although in handwriting, vector quantities are designated by an over-arrow (or a bar), it is more common to apply a bold style in printed documents (for example, \( F = mg \)).
- Compact math expressions and equations that will not be referenced elsewhere in the document should be embedded (inline) within a paragraph (e.g. \( y = ax^2 + b \)). For inline equations the fractions of the form \( \frac{a}{b} \) are preferred over stacked style \( \frac{a}{b} \).

As an example, formula 6.1 is written in accordance to these rules whereas formula 6.2 is not.

\[
  x_{1,2} = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \quad (6.1)
\]

\[
  x_{1,2} = \frac{-b \pm \sqrt{b^2 - 4a^2c}}{2a^2} \quad (6.2)
\]

If you use the equation editors bundled with Word, it’s usually best to stay with their default settings, which automatically match the surrounding text and mathematical tradition.
6.2. Aligning and numbering equations

Aligning a displayed equation and its number (as in the examples above) is fairly simple by defining a special style for that purpose. Create a new paragraph style (based on normal body text) and set two tab stops for it — one for positioning the equation and another for aligning its number. In the present document, for example, the first tab stop is at 8 cm centered whereas the second tab stop is at 15.5 cm right-aligned (Eqns. 6.1 and 6.2). Now that the EQUATION style is defined, create an empty (single-line) paragraph and set its style to EQUATION. Press [TAB] once and enter the equation. Press [TAB] once more and enter the number for the equation. The numbering and cross-referencing of displayed equations can be implemented in exactly the same manner as in the case of figures (see section 5.3). However, the References ▶ Insert Caption feature automatically applies the built-in CAPTION style to the paragraph which is totally pointless here. You may want to employ a macro that does the same job of creating the combination of STYLEREF and SEQ fields (see Appendix B).

As an alternative to tab stops, one can use a table (with invisible borders) for equation alignment [11]. This might be necessary for displaying a large equation in a multicolumn layout or when using the new equation editor introduced with Word 2007.

6.3. Creating equations

There are several different and inconsistent ways to create math in a Word document. First of all, it is sometimes completely reasonable to create simplistic inline expressions (like \( E = mc^2 \)) just by direct formatting of normal text (applying italics, bold, sub- and superscript as necessary) and using Insert ▶ Symbol to obtain special symbols. In previous versions of Word, the Microsoft Equation Editor (a cut-down version of MathType) was the general tool to prepare math. This old-fashioned equation editor is still available (Insert ▶ Text ▶ Object ▶ Microsoft Equation 3.0). Formulas 6.1 and 6.2 were prepared that way.

Word 2007 introduced a completely redesigned and arguably better approach to equation editing. The equations are written using a LaTeX-derived notation and are more natural ingredients of the document. The equation editor itself is also directly integrated into the Ribbon as a separate tab. In order to insert a new blank math region, select Insert ▶ Symbols ▶ Equation ▶ Insert New Equation (ALT+H). This creates an inline equation. Inline equations tend to be more compressed than displayed equations (which are on a separate line, not embedded in text). To change an inline equation to a displayed equation, activate the equation, click the downward arrow and select Change to Display. Although there is quite a complete selection of mathematical operators and symbols available in the equation editor tab, ideally an equation is typed in using just an intuitive keyboard sequence. For example, the formula

\[
x_{1,2} = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a}
\]

will be the result of the input \( x_{1,2} = (-b \pm \sqrt{b^2 - 4ac}) / 2a \). Here the final space (indicated by a square) is actually needed to complete the fraction. Sequences \( \text{\textbackslash pm} \) and \( \sqrt{\text{\textbackslash pm} \sqrt{\text{\textbackslash pm} (b^2 - 4ac) \text{\textbackslash pm}}} \) indicate actually AutoCorrect rules that transform to a plus/minus symbol and a square root operator, respectively (see also section 8.5). A more complete description of the equation editing can be found in Ref. [12]. Note that there seems to be no easy route to convert MathType equations to the new format (and vice versa).
CHAPTER 7. HANDLING BIBLIOGRAPHY

Scientific papers, dissertations and monographs virtually always contain a list of references (bibliography) which sometimes consists of hundreds of records. There are two main classes of citation styles: author-year or numerical. Author-year style is technically easy to implement. In the other case, however, all references are sequentially numbered and it’s hardly imaginable to manually update this list and the corresponding citations scattered all over the document. For bibliography numbering, one can employ the SEQ field (quite fool-proof and flexible), a numbered list (a bit more convenient but more fragile and not so flexible), footnotes/endnotes (a quick and dirty way to get the job done) or dedicated reference management software (by far the most complete solution).

7.1. Footnotes and endnotes

The simplest solution appears to be using footnotes or endnotes (References ▶ Footnotes). Unfortunately, there is no consistent way to cite a bibliography item more than once. A cheap trick is to create a cross-reference to an existing citation (Insert ▶ Links ▶ Cross-reference, select Footnote from Reference type). The formatting of footnote/endnote text is controlled through the internal styles FOOTNOTE TEXT/ENDNOTE TEXT whereas the number formatting is determined by FOOTNOTE REFERENCE/ENDNOTE REFERENCE. It is also possible to remove the horizontal separator line that Word automatically places between the list of notes and the main text. In the Draft view select References ▶ Footnotes ▶ Show Notes; this opens a special note pane near the bottom edge of the window. Select Endnote separator from the combo box near the top of the pane and delete the horizontal line.

7.2. Numbered list

The Insert ▶ Links ▶ Cross-reference tool allows referencing any numbered paragraph whether it is a heading or a list item of the body text. Therefore the numbered list can be used to implement the list of references. To reference a list item, click Insert ▶ Links ▶ Cross-reference, select Numbered item from Reference type, select Paragraph number from Insert reference to, and finally select the bibliography record you want to cite. There appears to be one limitation, though. If the list is customized such that the number is enclosed in brackets, then you are unable to cite multiple sources at a time. For example, if the list goes as [1], [2], [3], etc., then you can’t cite like [2, 4–7, 9].

7.3. SEQ field

Of the traditional built-in features of Word, the SEQ field seems to be the most flexible and reliable route for handling references. Therefore you need to start each bibliography record with something like { SEQ reference }. It is advisable to create a special style for references. You can employ the paragraph’s first line (hanging) indent in combination with tab stops to implement something that looks like a list (see page 25 for an example).

7.4. Dedicated reference management software

Even the approach with the SEQ field leaves unsolved one serious problem: once created, it will be impossible to automatically reformat either the bibliography or the citations (e.g. switch from a numerical style to an author-year style). Fortunately, specialized database
software exists to collect and manage bibliographic records [13]. The software integrates with word processors (through the use of macros, etc.) and fully controls the citing as well as the list of references in the document (citations and references are both implemented as fields to enable their automatic update). With a few mouse clicks a different citation style can be applied (to suite for the requirements of another journal, for example) and custom styles are easy to set up. In addition, such programs have the very useful ability to import records from web-based databases and other sources. A fairly popular commercial package seems to be EndNote [14] whereas a quite decent freeware solution is Zotero [15].

Note that Word 2007 has a promising new feature to handle the references (References \r
Citations & Bibliography), although it still seems to lack some essential abilities of dedicated software such as importing and exporting records, creating custom citation styles, etc.
CHAPTER 8. MISCELLANEOUS TASKS

8.1. Copying and pasting data from other applications

When you copy-paste data from another application supporting rich text formatting and multiple image formats (such as web browser, PDF viewer, e-mail client, etc.), Word tries to preserve as much of the original formatting as it can. However, this formatting is rarely what is needed as it does not adhere to the styles that were set up in the Word document. Then you can do one of the following:

- Use Edit ▶ Clipboard ▶ Paste ▶ Paste Special (CTRL+SHIFT+V) instead of Paste (CTRL+V). In the dialog box that appears, select Unformatted text or Unformatted Unicode text from the list box to remove any formatting (and graphics) and preserve just the raw sequence of characters (for handling figures, see Chapter 5).
- If you paste the text as usual then an icon like ☞ appears just after the pasted text. After clicking on that icon (or pressing CTRL) a drop-down menu appears containing various paste options. Use Destination Styles and Keep Text Only are the most fool-proof choices. Keep Text Only should be similar to the previous approach. It is possible to set any of the paste options as default for various situations (File ▶ Options ▶ Advanced ▶ Cut, copy, and paste).

It may still happen that the pasted text contains a number of excess line breaks. At this point it is useful to make various non-printing formatting characters in the document visible by clicking the button ¶ on the toolbar. There are two kinds of “hard” line breaks in Word: paragraph breaks (indicated by a ¶ symbol) and manual line breaks (indicated by a ← symbol). While a few unwanted line breaks are easy to fix manually, longer texts may require more serious means of attack. In this case the replace tool (Home ▶ Editing ▶ Replace) may become handy. In the replace dialog, press More to see some advanced options (Fig. 8-1). Position the cursor into the Find what textbox. At the bottom of the dialog, there is button labeled Special. After clicking on it a list of special (incl. non-visible) characters is displayed. For example, you can select Paragraph Mark or Manual Line Break, which are inserted into the textbox as special codes ¶ and ← (you may type the codes yourself). Into the textbox Replace with type a space. Then either press Replace All or play with Find next and Replace to confirm or reject each case individually. Similarly, empty lines (e.g. ^l^l) may be converted to paragraph breaks, multiple consecutive spaces to a single space, non-breaking space to ordinary space, etc.

8.2. Sections and page numbering

Word document can be divided into any number of sections. Each section can have different settings for paper size and orientation, margins, columns, headers & footers (incl. page numbering). To create a new section, execute proper command from Page Layout ▶ Page Setup.
Breaks. A newly created document consists initially of just one section. The markings of section breaks are toggled by pressing the button \( \text{¶} \) on the toolbar.

Note that Word sections have nothing to do with the logical division of the main text into parts, chapters, paragraphs, etc. (and the sections, subsections, etc. as used in LaTeX). Different sections might be useful, for instance, for separating front matter (title page, table of contents, preface) and body (main text) of a book.

A page number in Word is nothing but a field inserted usually into the header or footer area of the page. Each section can have different page numbering scheme (and header/footer contents in general). The number of a page within a section is determined by a starting value (usually 1) and the location of the page in the section. Note that the values of page numbers do not depend on whether they are actually displayed or not.

Although Word provides Insert \( \rightarrow \) Header & Footer \( \rightarrow \) Page Number command, a more robust and cleaner approach is to setup header/footer content manually. Double-click on the header or footer area to switch editing to that area. Position the cursor where you want the page number to appear and insert the field \{ PAGE \} to display the page number. Related useful fields are \{ NUMPAGES \} and \{ SECTIONPAGES \}, which allow implementing “Page X of Y” style of numbering. There are various more sophisticated (albeit seldom needed) tricks you can do with the fields related to page numbering [16].

Note also that a special Design tab becomes visible on the Ribbon if the header/footer area is activated. This provides quick access to all the fields as well as to other relevant tasks. In order to change the starting value of the page numbers for the current section, click the Design \( \rightarrow \) Header & Footer \( \rightarrow \) Page Number \( \rightarrow \) Format Page Numbers button. You have the option to continue the numbering from the previous section or type the desired value in the Start at textbox. Furthermore, the same dialog provides a possibility to modify the numbering scheme (Arabic, alphabetic, Roman).

Finally, note that by default the layout of headers and footers of all sections are the same because the sections are linked. You can link or unlink sections by toggling the Design \( \rightarrow \) Navigation \( \rightarrow \) Link to Previous button.

### 8.3. Customizing the table of contents

Table of contents is a TOC field that is conveniently created through the Reference \( \rightarrow \) Table of Contents \( \rightarrow \) Table of Contents \( \rightarrow \) Insert Table of Contents dialog. The depth of headings to be shown in the table of contents is determined by the Show levels value. The look of the table of contents is controlled by the built-in styles TOC1, TOC2, ..., where the number corresponds to the heading level. For example, the common right-aligning of the page numbers (with a leader dotted line) is achieved by setting a proper tab stop. If these styles are not visible in the Styles task pane, you can still easily access them by opening the Table of Contents dialog and pressing the button Modify located at the lower right corner. However, it seems that automatic update is enabled for the styles by default so that any direct formatting of the table of contents entries should modify the styles correspondingly. If necessary, table of contents based on any styles (not just the built-in heading styles) can be set up by clicking the Options button.

![Figure 8-2: The dialog for setting up a table of contents.](image)
8.4. Creating appendices

The problem with appendices is that they are usually subject to a different type of numbering scheme than the main headings, such as Appendix A, Appendix B, ..., instead to Chapter 1, Chapter 2, .... Therefore you can’t employ HEADING 1 for that purpose. A common solution is to exploit a heading style that is not in use for titles in the main part of the document, say HEADING 7 (it is very improbable that you need so deep nesting of headings, therefore this style should be unemployed). Renaming of the style is also allowed.

1. In the Home ➤ Paragraph ➤ Multilevel List menu find the list style corresponding linked to headings, right-click on it and select Modify. On the dialog select Format ➤ Numbering which finally opens the dialog to manage the numbering properties. In the Level list, click 7. In the Enter formatting for number text box, type Appendix in front of the number. From the Number style for this level list box select A, B, C, ... Click More. From the Link level to style list select Heading 7 and click OK. You may also play with the alignment options. Finally, modify the font and paragraph settings of HEADING 7 style as appropriate. For example, if you want the appendix titles look exactly like HEADING 1 (as in this document), you may choose HEADING 1 as the base style.

2. In order to incorporate appendices into the table of contents, open the Insert ➤ Reference ➤ Index and Tables ➤ Table of Contents dialog and click Options. To show HEADING 7 titles in table of contents at the same level as HEADING 1 titles, type “1” into the TOC level box to the right of Heading 7 in the Available styles list. Clear the Outline levels check box. Click OK twice.

3. If you would like to change figure, table or equation numbering scheme to include appendix number, you need to modify the STYLEREF and SEQ fields accordingly to reference level 7 headings (see section 5.3).

8.5. AutoCorrect

The AutoCorrect feature (File ➤ Options ➤ Proofing ➤ AutoCorrect Options) allows Word to automatically respond to specific input patterns. It usually operates in the background to correct some common typing errors but from the scientific/technical writer’s point of view the feature can be used to easily insert special characters (for instance, transforming the character sequence -- into an arrow →). Furthermore, one can attribute convenient abbreviations to some frequently encountered complicated phrases, like “Schrödinger equation” or “Hertzsprung-Russell diagram”, etc. If Word applies an AutoCorrect rule you didn’t expect, just press CTRL+Z or BACKSPACE. In addition, an icon like $\alpha$ appears just below the word on which the AutoCorrect rule was applied. Clicking the icon reveals a menu where you can find a proper command to permanently disable an annoying AutoCorrect rule. With the introduction of the new equation editor in Word 2007, the AutoCorrect feature now also includes an additional set of rules (File ➤ Options ➤ Proofing ➤ AutoCorrect Options ➤ Math AutoCorrect) which allow entering special mathematical characters and operators by typing the corresponding LaTeX commands (e.g. \alpha for $\alpha$, \sqrt for square root, and so on).
MS Word has had typically one of the best user interfaces in terms of usability and customizability. Previous Word versions allowed nearly complete redesign of all menus and toolbars (which is typically unnecessary). Although Word 2007/2010 does not permit removing or changing the existing items on the built-in tabs of the Ribbon, one can still add custom control groups to any tab and can also create new tabs. There is also a new Quick Access Toolbar (placed directly on the title bar and always accessible). As in previous versions, it is still possible to create macros (scripts for automating repetitious tasks) and associate custom keyboard shortcuts to commands, macros and styles.

If you have customized Word a lot, you may want to store the workspace in a file, and on another installation reload the workspace from a file. To do that, right-click anywhere on the Ribbon and select Customize the Ribbon » Import/Export.

9.1. Customizing the ribbon

To customize the Ribbon, right-click anywhere on the Ribbon and select Customize the Ribbon. The dialog contains two tall lists side by side. On the right list select the tab to add controls to (or create a new tab). Then create a new control group. With this control group active, find the command of interest from the left list and click Add. Right-clicking on any custom group or control on the right list allows renaming or assigning an icon to the element. Customizing the Quick Access Toolbar is even simpler: just right-click on any control or control group on the Ribbon and select Add to Quick Access Toolbar from the context menu.

9.2. Using and customizing hotkeys

In a text processing application there is usually a relatively small number of commands that are required the most, and it can be time-consuming to hunt the commands from the Ribbon with the mouse. First of all, there is a set of hotkeys (shown to the right) that are so widely recognized on the PC platform that nearly all well-designed applications support them. In particular, to minimize the possibility of losing work due to an unexpected system failure, one should develop the habit of pressing \texttt{CTRL+S} whenever he’s making a pause in editing. Pressing \texttt{CTRL+Z} is a quick way to reverse the last action. The maximum number of undo levels in Word is allegedly limited by system resources only (not true for the other programs in the office suite) meaning that you may fairly confidently experiment with editing and recover the initial state if situation is getting out of control. There is even matching multi-level Redo to reinstate accidentally undone actions. If you click the downward arrow next to the Undo (or Redo) button on the Quick Access Toolbar, you will get a detailed list of all undoable (redoable) actions. This provides a convenient way to undo (redo) a great amount of editing at once. Understandably undo and redo capability is limited to current editing session only.

You will also find the following editing and navigational shortcuts very useful in MS Word:
Special characters and formatting marks

<table>
<thead>
<tr>
<th>Character</th>
<th>Keyboard Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>En-dash</td>
<td><code>CTRL</code> + (NumPad)<code>-</code></td>
</tr>
<tr>
<td>Non-braking space</td>
<td><code>CTRL</code> + <code>SHIFT</code> + <code>SPACE</code></td>
</tr>
<tr>
<td>Non-braking hyphen</td>
<td><code>CTRL</code> + <code>-</code></td>
</tr>
<tr>
<td>Optional hyphen</td>
<td><code>CTRL</code> + <code>_</code></td>
</tr>
<tr>
<td>Manual line break</td>
<td><code>SHIFT</code> + <code>ENTER</code></td>
</tr>
<tr>
<td>Manual page break</td>
<td><code>CTRL</code> + <code>ENTER</code></td>
</tr>
</tbody>
</table>

Navigational commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous/next word</td>
<td><code>CTRL</code> + <code>LEFT</code>/<code>RIGHT</code></td>
</tr>
<tr>
<td>Previous/next page</td>
<td><code>CTRL</code> + <code>PAGE UP</code>/<code>DOWN</code></td>
</tr>
<tr>
<td>Beginning/end of document</td>
<td><code>CTRL</code> + <code>HOME</code>/<code>END</code></td>
</tr>
<tr>
<td>Zoom in/out</td>
<td><code>CTRL</code> + <code>MOUSE WHEEL</code></td>
</tr>
<tr>
<td>Go back</td>
<td><code>ALT</code> + <code>LEFT</code></td>
</tr>
<tr>
<td>Previous editing location</td>
<td><code>SHIFT</code> + <code>F5</code></td>
</tr>
</tbody>
</table>

Formatting

<table>
<thead>
<tr>
<th>Format</th>
<th>Keyboard Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Italic</td>
<td><code>CTRL</code> + <code>I</code></td>
</tr>
<tr>
<td>Bold</td>
<td><code>CTRL</code> + <code>B</code></td>
</tr>
<tr>
<td>Underline</td>
<td><code>CTRL</code> + <code>U</code></td>
</tr>
<tr>
<td>Subscript</td>
<td><code>CTRL</code> + <code>=</code></td>
</tr>
<tr>
<td>Superscript</td>
<td><code>CTRL</code> + <code>+</code></td>
</tr>
<tr>
<td>Reset character</td>
<td><code>CTRL</code> + <code>SPACE</code></td>
</tr>
<tr>
<td>Reset paragraph</td>
<td><code>CTRL</code> + <code>F3</code></td>
</tr>
<tr>
<td>Change case</td>
<td><code>SHIFT</code> + <code>F3</code></td>
</tr>
<tr>
<td>Apply NORMAL style</td>
<td><code>CTRL</code> + <code>SHIFT</code> + <code>N</code></td>
</tr>
</tbody>
</table>

Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Keyboard Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert field</td>
<td><code>CTRL</code> + <code>F9</code></td>
</tr>
<tr>
<td>Update field</td>
<td><code>F9</code></td>
</tr>
<tr>
<td>Insert equation</td>
<td><code>ALT</code> + <code>=</code></td>
</tr>
</tbody>
</table>

In order to assign/modify hotkeys, right-click anywhere on the Ribbon and select Customize the Ribbon ▶ Customize. Find and select the command, then move the focus to the textbox labeled Press new shortcut key, press the desired combination of keys, and finally press Assign. Note that Word automatically handles the possibility that the hotkey might already be assigned to another command, so there is no need to manually remove the previous assignment.
9.3. Macros

In the preparation of a long structured document, various editing patterns arise involving a well-defined series of actions (for example, creating a figure number using the SEQ and STYLEREF fields as explained in section 5.3). It is possible to record the series of actions as a macro (Developer ▶ Code ▶ Record Macro) and assign a toolbar button or a shortcut to the macro (note that the Developer tab is not visible by default). In order to create smart, convenient and error resistant macros, it may be necessary to manually edit the macro code using the Visual Basic editor (Developer ▶ Code ▶ Visual Basic). Initially, record the macro close to what you would like to implement and later in the code editor try to decipher and modify the macro code that Word creates. It is much faster than trying to code the macros from scratch by learning the VBA scripting language. The macro editor is also quite convenient due to the “Auto List Members” feature and context-sensitive help. Some useful macro examples are collected in Appendix B.
REFERENCES AND SUGGESTED READING


APPENDIX A. VARIOUS MS WORD TIPS AND TRICKS

1. For easier navigation in long documents one can use the document map (View ▶ Show ▶ Navigation Pane or View ▶ Show ▶ Document Map) which provides a quick hyperlinked table of contents of the document based on the titles which have the built-in heading styles assigned [17]. The navigation pane (which hosts the document map) also contains a basic search tool; therefore it can be activated with $\text{CTRL}+F$.

2. The split view (View ▶ Window ▶ Split) provides two different views of the same document and might be useful for comparing or copying of text from different parts of the document.

3. MS Word keeps track of the last three locations where the document was edited. Press $\text{SHIFT}+F5$ to go back to the previous editing location. You may also press $\text{SHIFT}+F5$ immediately after opening the document to resume editing at the location where you last made a change.

4. In order to select rectangular columns of characters hold down $\text{ALT}$ while dragging the mouse (a common behavior also present in some other advanced text editors). This feature might be useful for trimming leading spaces from pasted text, etc.

5. Word permits selecting multiple, noncontiguous blocks of text. Just hold down $\text{CTRL}$ when selecting the pieces of text.

6. To reveal complete formatting information about some part of the document, open the Reveal Formatting task pane ($\text{SHIFT}+F1$) and select the text you are concerned about. To determine the formatting source (whether the formatting is due to a style, etc.), mark the Distinguish style source check box. Might be useful for troubleshooting purposes.

![Figure A-1: The Reveal Formatting task pane.](image-url)
APPENDIX B. SOME USEFUL MACROS

To use these macros, open the Visual Basic editor (Developer ➤ Code ➤ Visual Basic), activate Normal in Project Explorer, select Insert ➤ Module and paste the code.

The next macro transforms the last typed (or selected) Latin letter to the corresponding Greek letter of the “Symbol” font (assign a convenient shortcut to the macro, like $\text{CTRL}+\text{G}$):

```vba
Sub ConvertToGreek()
    If Len(Selection.Range) = 0 Then Selection.Start = Selection.Start – 1
    code = Asc(Selection)
    Selection.InsertSymbol code – 4096, "Symbol", True
End Sub
```

Paste clipboard content as unformatted text (e.g. $\text{CTRL}+\text{SHIFT}+\text{V}$):

```vba
Sub PastePlainText()
    On Error GoTo PasteError
    Selection.PasteAndFormat wdFormatPlainText
End PasteError:
    MsgBox "Couldn't find any text on clipboard!"
End Sub
```

Open the most recently edited document (from the list of recent files) and locate the cursor at the position where the document was last edited:

```vba
Sub ResumeLastDocument()
    RecentFiles(1).Open
    Application.GoBack
End Sub
```

Insert the next figure number prefixed with the chapter number:

```vba
Sub InsertSequence()
    Selection.Fields.Add _
        Selection.Range, wdFieldEmpty, "STYLEREF 1 \s", True
    Selection.TypeText "-"
    Selection.Fields.Add _
        Selection.Range, wdFieldEmpty, "SEQ Figure \s 1", True
End Sub
```

Update all fields in the document:

```vba
Sub UpdateAllFields()
    Selection.WholeStory
    Selection.Fields.Update
    If ActiveDocument.TablesOfContents.Count >= 1 Then
        For i = 1 To ActiveDocument.TablesOfContents.Count
            ActiveDocument.TablesOfContents(i).Update
        Next i
    End If
    If ActiveDocument.TablesOfFigures.Count >= 1 Then
        For i = 1 To ActiveDocument.TablesOfFigures.Count
            ActiveDocument.TablesOfFigures(i).Update
        Next i
    End If
End Sub
```