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Funktsioonid,  arvutustulemused, mõõtühikud

Funktsioonid 

Funktsioonide defineerimise jaoks tuleb kirjutada 
esmalt funktsiooni nimi, siis sulgudes lokaalsed 
muutujad, omistamise märk ":=" ja seejärel funktsiooni 
avaldis. Argumendid on eraldiseisvad lokaalsed muutujad 
ja neil ei pea olema varem omistatud väärtusi. Argumentide
nimed peavad olema lihtnimed, s.t. võivad omada 
iluindekseid, kuid mitte massiivide indekseid.
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Ruutlahend 1 3−, 1−, ( ) 2.303−=

Funtksioonide nimed on tõstutundlikud, s.t. Mathcad
teeb vahet suur- ja väiketähtedel.

ruutlahend 1 3−, 1−, ( ) =ruutlahend

Kui funktsiooni sees kasutatakse muutujat, mis ei ole argument, siis kasutatakse selle muutuja
jaoks varasemalt salvestatud väärtust. Targem on selliste kohta peal võtta muutuja samuti
funktsiooni argumendiks (hoides ära hilisemaid arusaamatusi).

Näide

a 3:=Olgu muutuja a väärtus 3.

Defineerime astmefunktsiooni. aste x( ) x
a

:=

Funktsiooni väärtus kohal 2. aste 2( ) 8=

Kuid meie funktioon ei sõltu enam muutujast a,
see fikseeriti funktsiooni defineerimise hetkel.

a 6:=

aste 2( ) 8=

Kasulikum ja selgem oleks olnud defineerida aste(x,a): aste x a, ( ) x
a

:=

aste 2 6, ( ) 64=

Vektorfunktsioonid 

Kui on soov arvutada funktsiooni väärtust maatriksist
või vektorist, siis tuleb funktsioon vektoriseerida. 
Selleks tuleb funktsiooni osa teha aktiivseks ja võtta
"Matrix" paletilt "Vektorize". Tulemusena rakendatakse
funktsiooni igale maatriksi või vektori elemendile.
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Funktsiooni annab defineerida ka vektorfunktsioonina.

Näiteks: argument x on tavaline muutuja, kuid 
funktsiooni arvutuseeskirjas pöördume muutuja poole
massiivi indeksiga. Lihtsamal juhul peab meil siis teada
olema, mis mõõdus maatriksitega funktsiooni kasutama
hakatakse. Kaasates argumentideks ka indeksid i ja j
saame paindlikuma funktsiooni.

fun x i, j, ( ) x
i j, 

x
i j 2+, 

+:=

fun M 0, 0, ( ) 4=

fun M 1, 0, ( ) 10=



Arvutustulemustega opereerimine

Mathcad kasutab arvutuste jaoks järgmist kolme põhimõtet.

1. Ekraanil näidatakse arve "ekraanitäpsusega", mis on vaikimisi 3 komakohta. Seda saab muuta,
kui tulemusel klikates valida menüüst "Format" => "Result" => "Number of decimal places".
Töötab ka lihtne hiire topeltklõps tulemuse peal.  Kogu töölehel saab tulemused väljastada samas
formaadis, kui klikata hiirega piirkonnas, kus ei ole hõivatud regioone ning valida sama käsk
"Format" => "Result" => "Number of decimal places". 

Ekraanil näitamiseks saab veel valida,
kas tulemusi näidatakse tavalises
formaadis või näiteks teaduslikus,
inseneri või murdude formaadis.

sin 5( ) 0.959−=

sin 5( ) 0.9589242747−=

sin 5( ) 9.589− 10
1−

×=

sin 5( ) 958.924− 10
3−

×=

sin 5( )
764768

797527
−=

NB! Arvulisi väärtusi kopeeritakse lõika-kleebi meetodiga nii, nagu neid ekraanil näidatakse ehk siis
ekraanitäpsusega.

2. Mälus hoitakse arvud topelttäpsusega ujukoma arvudena (vt all pool), kus mantissi jaoks
kasutatakse 17 tüvenumbrit. Peab arvestama, et ekraanil nähtu võib oluliselt erineda mälus olevast
arvust, kui näiteks ekraanitäpsus on valitud liiga väike.

x 1.0001:= Näiteks võtame sellise arvu.

x 1= Kuna vaikimisi on ekraanitäpsus 3 komakohta, siis näeme, et x=1.

x 1.0001= Menüü "Format" => "Result" abil suurendame ekraanitäpsust ja
võime veenduda, et samal ajal mälus hoiti arve õigesti.

3. Sümbolarvutuste jaoks teisendatakse sisestatud ujukomaarvud Mathcadi enda arvuformaati ja
sellisel juhul võib arvutada käsuga "float" kuni 4000 tüvenumbri täpsusega. Selline arvutus on
täpsem, kuid samas kordades aeglasem, kui arvuti enda ujukomaarvude kasutamisel saadu.

Arvutustulemuste lõpetamiseks vajutage klahvi "ESC".

Arvutusi saab ühe avaldise jaoks keelata menüüst
"Format"=>"Properties"=>"Calculation"=>"Disable Evaluation". Sel
juhul ilmub valemi juurde must kastike.

Kõikide valemite jaoks saab automaatse arvutamise keelata menüüst
"Tools"=>"Calculate"=>"Automatic Calculation".

i 0 1000..:=

sin i( ) =

2



Arvutuslik täpsus ja IEEE standard 754

Mathcad kasutab arvutamiseks standardseid 64 bitise topelttäpsusega (double precision)
ujukoma arve, inglise keelse väljendiga IEEE (Institute of Electrical and Electronics Engineers) 

Standard 754 (vt [2], [6], [7]). Iga kümnendsüsteemi arv a 10
b

⋅  on mälus salvestatud
kahendsüsteemis kujul

S EEEEEEEEEEE MMMMMMMMMMM...MMMMMMMMMM

Siin S on märgile eraldatud bitt, E on astmele eraldatud 11 bitti ja M on mantissile eraldatud 52
bitti. Iga biti jaoks kasutatakse kahendsüsteemis väärtusi 0 ja 1.

IEEE standard 754 lubab kõige väiksema nullist erineva arvuna esitada kümnendsüsteemi arvu

2.2250738585072020 10
308−

⋅  ja kõige suurema arvuna 1.7976931348623157 10
308

⋅ . Mathcad

kasutab lõpmatuse märgi väärtuseks 10
307

 ja kõige väiksem nullist erinev arv on 10
307−

. 

Märgime, et kui arv algab nullidega, siis neid nulle ei salvestata mantissi, vaid võetakse

arvesse astmenäitajas (s.t. näiteks 0,001 annab kirjutada kui 1 10
3−

⋅ ).

a 1234567890.1234567:=

b 1234567890.12345678:= Kui me võtame sellise arvu "a", siis rohkem
komakohti meil ei õnnestu salvestada.

c 1234567890.123456:=

a c− 7.152557373046875 10
7−

×= Vahe (a-b) tulemuseks on null, sest Mathcad ei
salvestanud muutuja "b" viimast komakohta (rohkem ei
ole bitte, kuhu seda väärtust salvestada).

a b− 0=

Kontrolliks valime ekraanil näitamiseks maksimaalselt
lubatud 17 tüvenumbrit ja korrutame veel suure arvuga.10

15
a b−( ) 0.00000000000000000=

Näide. Nullidega algavate arvude korral salvestab Mathcad õigesti.

cc 0.0000000000000000000000012345:= Omistame muutujale "cc" ühe väiksema arvu, milles on
rohkem kui 17 nulli.

cc 0= Ekraanitäpsus loeb väärtuse nulliks.

Menüüst "Format"=>"Result" valime 17 tüvenumbrit ja
näeme, et need esimesed nullid võeti arvesse. Kuid
paneme tähele viimast komakohta 2, mis tegelikult
reaalelus peaks olema null. Kahjuks arvutite puhul see
nii ei ole ja isegi siin tuleb sisse ümardamisviga
(enamus kümnendsüsteemi arve ei ole võimalik täpselt
esitada  lõpliku pikkusega kahendsüsteemi formaadis).

cc 1.2345000000000002 10
24−

×=

3



Nullilävi ehk "Zero threshold" on väärtus, mis näitab, kui lähedale nullile peab 10 astmetes
esitatud arv olema, et Mathcad näitaks seda ekraanil nullina. Vaikimisi on astme väärtus -15.

Omistame, võrduse järel kuvatakse erkaanile x
ekraaniväärtus. x 1.52 10

15−
⋅ 1.52 10

15−
×=:=

Proovime väiksema arvuga. Meenutame, et IEEE standardi
järgi peaks selle arvu jaoks mälus olema piisavalt ruumi.x 1.52 10

21−
⋅ 0=:=

x 1.52 10
21−

×= Valime menüüst "Format" => "Result" => "Tolerance" =>
"Zero threshold" ja muudame väärtuse 15 väärtuseks 22.
Jällegi näeme, et ekraaniväärtus ja mälus olevad väärtused
olid erinevad.

Sümbolarvutuse vahendid

Arvutustulemusi on Mathcadis võimalik ujukoma arvutuste asemel leida ka analüütiliselt (vt
[5], [6]). Selleks tuleb arvutustes võrdusmärgi "=" asemel kasutada noolekest → , paletilt
"Evaluation" või "Symbolic" või siis klaviatuurilt "Ctrl"+"punkt". Võrdusmärki ja noolekest
annab kasutada ka üksteise järel.    
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float 60, 0.760244597075630151253547198623274394617583171135131208568028→

Siin kasutatakse peidetult sümbolarvutuse vahendit
"float", mille täpsus on vaikimisi 20 tüvekohta. Erinevus
eelmise reaga tuleb sellest, et esitasime 17
ujukomaarvuna 17.0.

17 17→

17.0 4.1231056256176605498→

Näide. Vaatame ühte ülemist näidet, kus ujukoma arvudega opereerimine oli probleem.

a 1234567890.1234567:=

b 1234567890.12345678:= Ujukoma arvuna viimast komakohta ei salvestata.

10
15

a b−( ) 0.00000000000000000= Tulemus on null.

a b− float 12, 8.0e-8−→ Kasutades sümbolarvutuse vahendeid ja käsku "float"
näeme, et muutujad "a" ja "b" loetakse uuesti sisse
ning seekord siis juba Mathcadi enda laiendatud 
arvuformaadis ning tulemus (a-b) on oluliselt täpsem.
Selline laiendatud arvuformaat on veel omane
sümbolarvutuse programmidele nagu näiteks Maple,
Maxima, Mathematica.

Mõõtühikud 

Üks Mathcadi erinevus teiste arvutusprogrammidega on mõõtühikute kasutamise võimalus.
Tuntuim neist on SI mõõtühikute süsteem. 
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Mathcad tõlgendab ühikuid konstantidena.

Olemasolevaid ühikuid näeb menüüst "Insert" => "Unit..." või siis valemis tuleb viimasel mustal
kastikesel teha hiirega topeltklõps. 

Ühikute kasutamise üheks eeliseks on see, et selle abil võib pisut lihtsamalt avastada valemi
trükkimisel tehtud vigu. Teine väga mugav vahend on näha oma tulemust erinevates ühikutes.

g 9.807
m

s
2

= Paljudel globaalsetel muutujatel võib Mathcadis juba
olemas olla väärtus mõõtühikute näol. Näiteks
gravitatsioonikonstant g. Kontrolliks saab alati kasutada
võrdusmärki "=", mille järel kuvatakse ekraanile tulemus.

sin g( ) =g Kui avaldist ei saa arvutada, kuna probleem on ühikute
mittesobivuses, siis saab arvulise tulemuse saamiseks
kasutada võtet, kus muutuja jagatakse läbi temal oleva
ühikuga. Muutujal olevat ühikut näeb käsuga "UnitsOf". 

UnitsOf g( ) 1
m

s
2

=

sin
g

UnitsOf g( )
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Näide. (vt [1]) Tulemuse vaatamine erinevates ühikutes.

d 1m:= Omistame muutujale "d" üks meeter ja muutujale "t" üks
sekund.t 1s:=

Tulemusi saab üsna l ihtsalt näha teis tes ühikutes. Kui
te palute võrdusmärgiga "=" kuvada tulemus ekraanile, siis
avaldise lõppu ilmub must kastike, mis ongi mõeldud
ühikute muutmiseks.

v
d

t
1

m

s
=:=

Kui sellesse tagumisse kasti midagi kirjutada, siis võib
tulemus küll kaduda, kuid teile kuvatakse selline mustade
kastikestega avaldis, kuhu te saate viimases jagatises
panna enda poolt soovitud ühikud ja pärast kastist väljumist
ilmub tulemus juba uute ühikutega ekraanile.

v 100
cm

s
⋅= Trükime lugejasse "cm" ja nimetajasse "s". Nii saamegi

tulemuse cm/s.

Kilomeetrit päevas (valides näiteks menüüst "Insert" =>
"Unit" ajaühikuks "day" ja pikkusühikuks "km").v 86.4

km

day
⋅=

v 1.961 10
4

×
mi

yr
⋅= Või siis miili/aastas.
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Näide. Kasutaja poolt uute ühikute defineerimine (palju huvitavaid näiteid leiab viitest [4]).

day 8.64 10
4

× s= Mathcadi üks ajaühikutest on päev ja võrdub see 86400
sekundit.

päev 1day:= Defineerime 1 päeva ja 1 nädala.
nädal 7 päev⋅:=

14nädal 98 päev⋅= Kasutame. Kui Mathcad annab tulemuse mingites muudes
ühikutes näiteks nagu sekundites, siis muudame selle ise ära.

53.5päev 7.643 nädal⋅=

Näide. Rahaühikud.

kroon ¤:= Valime "Insert" => "Unit" => "Money" => "Base Currency".
Tulemuseks on selline "imelik"  märk.

euro 15.6466kroon:=
Uus-äge-mega-vahva ipod maksab nii mitu eurot ja nii mitu
krooni.hind 154.5 euro⋅:=

hind 2417.4 kroon⋅=

Näide. Rahaühikud, baashind.

EUR ¤:= Defineerime euro baasühikuks

Majanduse üks mõõtühikuid on Big Maci hind. Aastal 2013 on
see Eestis u 2.7 eurot, Iirmaal 3.5.HB 2.7 EUR⋅:=

Kohviubade hind on u 10 euot kilogramm.
kohvi 10

EUR

kg
⋅:=

kohvi 3.704
HB

kg
⋅= Kohviubade hind hamburgerites.

5.6 kg⋅ kohvi⋅ 20.741 HB⋅= 5.6 kg kohviubade hind.

kohvi 0.074
HB

20 gm⋅
⋅= Mathcadis saame lihtsalt näiteks 20 grammi kohviubade hinna

Big Macides. Ühikute lahtrisse võib kirjutada ka arve.
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Kokkuvõte 

Ära usu alati seda, mida ekraanil näed. Mathcad kasutab arvutuste jaoks eraldi "ekraanitäpsust"
ja mälus hoitavat ujukomaarvu täpsust (mantissi 17 tüvenumbrit). Arvutamise käigus on
ümardamisvead paratamatud juba kasvõi sellepärast, et enamus reaalarve ei ole võimalik
kahendsüsteemi täpselt teisendada. Arvutustäpsuse suurendamiseks on võimalik kasutada
sümbolarvutuse jaoks mõeldud vahendit "float", kuid peab arvestama, et see
vahend on aeglane mahukate arvutuste korral. Tavaliselt on võimalik enamus arvutusi läbi viia
kiiremas ujukomaarvu režiimis ja ainult üksikud tähtsad kohad arvutatakse sümbolarvutuse
vahenditega.

Mõõtühikud on üks Mathcadi eripäradest. Ole ettevaatlik muutujate nimetamisel ja nende
kasutamisel, kui samal ajal kasutad ka mõõtühikuid. Arvesta, et kui juba alustasid mõõtühikute
kasutamist, siis Mathcad nõuab nende olemasolu kõikides seotud avaldistes. Kui viimane
muutub tüütuks, siis kasulikum on ühikuid kasutada lõpptulemustes, vahearvutustes võib siis
opereerida ainult arvudega. 
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