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Ülesanne 
Selle praktikumi käigus on meil ülesandeks 

 defineerida andmete matemaatiline alus 

 päringuid kasutades valmistada ette järgmises ülesannetes vajaminevaid 

andmeid 

 ruumipäringute tegemiseks laadida geoandmebaasi vajalikud andmed, mis on 

muudes formaatides 

Tulemus 
Praktikumi lõpuks oskate: 

 omistada andmetele projektsiooni-infot 

 transformeerida andmeid ühest koordinaatide süsteemist teise 

 tundmatul matemaatilisel alusel olevaid andmeid koolutada vajalikku 

projektsiooni 
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 teha ruumipäringuid ning tulemusi salvestada 

 teha päringuid atribuutandmete abil 

 laadida geoandmebaasi CAD, DBF ja SHP formaadis andmeid 

1. Matemaatiline alus 
ArcMap võtab vaikimisi kogu kaardi koordinaatsüsteemiks (e. salvestab 

kaardidokumenti kaardi koordinaatsüsteemiks) raamkihile defineeritud 

koordinaatsüsteemi. ArcMap’i esimesena laaditud kihi koordinaatsüsteem defineerib 

raamkihi koordinaatsüsteemi automaatselt. 

See tähendab seda, et kõiki kaardikihte näidatakse teile selles koordinaatsüsteemis. 

 

Oluline erinevus on geoandmebaaside projektsiooni-infol. Nimelt ei ole 

geoandmebaasile võimalik projektsiooni-infot lisada, küll aga saab omistada 

projektsiooni andmeid kõikidele raamobjektidele ning objektiklassidele selle 

andmebaasi sees. 

 

Ruumiandmetega töötamisel puutute kokku järgmiste matemaatilise aluse määramise 

meetoditega: 

- info lisamine – kasutate siis, kui andmetele pole projektsiooni-infot lisatud, 

kuid te teate täpselt, mis projektsioonis andmed on 

- transformeerimine, kasutate siis, kui teie andmestikule on omistatud 

korrektne projektsiooni-info, kuid teil on see vaja ümber arvutada mingisse 

teise, teile teada olevasse projektsiooni 

- koolutamine, kasutate, kui ei tea, mis projektisoonis on andmed, kuid teate 

täpselt, mis projektsioonis te töötate (ehk millisesse projektsiooni tahate 

andmed üle viia) 

 

Järgnevalt vaatame lähemalt, kuidas need meetodid töötavad. 

1.1. Projektsiooni-info lisamine 

1.1.1. Defineerime 

 Avage ArcMap 

 Sakk Catalog 

 Kataloogipuus valige ASULA2, parem hiireklõps > Properties > sakk XY 

Coordinate System 

Avanenud dialoogiaknas Name näete sõna Unknown, mis tähendab seda, et antud 

andmestikul projektsiooni-info puudub. Kuna kogu käesoleva kursuse raames 

kasutatud andmestik on Eesti põhikaardi projektsioonis, siis lisame selle info. 

 nupp New > Projected 

 Täitke lahtrid alljärgnevalt (võimalusel kasutage lahtrites pakutud vaikevalikuid) 
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Name L-EST97 

Projection Name Lambert_Conformal_Conic 

False_Easting 500000 

False_Northing 6375000 

Central_Meridian 24,0 

Standard_Parallel_1 58,0 

Standard_Parallel_2 59,333333333(kraadid on arvutatud 

sajandiksüsteemi) 

Scale_Factor 1 

Latitute_Of_Origin 57,517553930555557 

Linear Unit Name Meter 

Geographic Coordinate System > 

Select 

Europe>Estonia 1997.prj 

 Finish > OK 

Eesti riiklik koordinaatsüsteem on juba ArcGIS-i tarkvara jaoks kirjeldatud. 

Järgmisena lisamegi projektsiooni info mallist. 

1.1.2. Projektsioonimallist info lisamine 

Järgnevalt vaatame, kuidas on võimalik projektsiooni-infot lisada juba valmisolevast 

mallist (*.prj). 

 Kataloogipuus jõed > parem hiireklõps > Properties > XY Coordinate System 

 topeltklõps Projected Coordinate Systems > National Grids > Europe > 

Estonia 1997 Estonia National Grid 

 OK 

1.1.3. Projektsiooni-info importimine 

Sisestada projektsiooni parameetreid igale kihile on üpriski aeganõudev. Kui 

soovime, et uue kihi projektsiooni parameetrid oleksid identsed juba olemasoleva kihi 

projektsiooni parameetritega, kasutame projektsiooni-info importimist 

 Kataloogipuus valige kiirteed, parem hiireklõps > Properties > XY Coordinate 

System 

 Nupp Import > ArcGIS\jõed.shp>Add> OK 

 Kataloogipuus valige ASULA2, parem hiireklõps > Properties > XY Coordinate 

System 

 Nupp Import > ArcGIS\jõed.shp>Add> OK 

1.2. Transformeerimine 

Transformeerimise all mõistame ruumiandmete koordinaatide ümberarvutamist ühest 

koordinaatide süsteemist teise. 
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1.2.1. Näivtransformatsioon 

Näivtransformeerimine toimub siis, kui projektsiooni-info on andmestikule 

omistatud, kuid see erineb antud kaardidokumendi raamkihi koordinaatide 

süsteemist. 

1. Millised on projektsiooni-info olemasolu kontrollimise võimalused 

a. ArcCatalog’is (vähemalt 2 ) 

b. ArcMap’is 

Erineva projektsiooni-infoga andmekihid visualiseeritakse ArcMap’is aktiivses 

(raamkihile määratud) koordinaatide süsteemis, mis tähendab, et kui avate ühe ja 

sama ala kohta erinevad andmekihid, siis kuvatakse nad tööaknas kohakuti.  

Oluline on siinkohal rõhutada, et visualiseeritakse, kuid ei salvestata. Näival 

transformeerimisel arvutatakse koordinaadid küll ümber, kuid ei salvestata 

andmefaili, ei muudeta füüsiliselt andmete projektsiooni-infot 

 Käivitage ArcMap 

 Tutvuge Catalog’is est_prov projektsiooni-infoga.  

2. Kas kihil est_prov on olemas projektsiooni-info? Kui on, siis milline? 

 Lisage kaardidokumenti kaardikiht -  Teemad geoandmebaasist objektiklass 

Maakond (kasutage nuppu  Add Data) 

 Muutke maakonda kujutav leppemärk seest tühjaks, servajoon tumesinise 

joonega, laius 2. 

 Lisage kiht est_prov 

 Juhul, kui ilmub dialoogiaken: nupp Transformations > Convert from: 

GCS_ETRS_1989, Into GCS_Estonia_1997 >OK >Close 

Kaks lahti olevat kihti on enam-vähem kohakuti, vaatamata sellele, et nendel kihtidel 

on defineeritud erinevad projektsioonid. 

 Eemaldage kiht est_prov (parem hiireklõps > Remove) 

Kui aga laadite aktiivse projektsiooniga ArcMap’i andmekihi, millel puudub 

projektsiooni-info, visualiseeritakse laaditavad andmed tööaknas juba olemasolevate 

andmekihtide suhtes teie jaoks ettearvamatusse kohta.  

 Tutvuge Catalog’is est_count projektsiooni-infoga.  

3. Kas kihil est_count on olemas projektsiooni-info? Kui on, siis milline? 

 Lisage kiht est_count kaardidokumenti 

4. Kuidas veel, lisaks Add Data nupule, saab kaardi kihti lisada? Vihje: viibite hetkel 

Catalog tööaknas. 

 Sulgege hoiatusaken OK. 
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 Muutke leppemärk seest tühjaks, servajoon lilla, laius 4 

Lillade piiridega maakonnad tööaknasse ei ilmunud! Otsime nad üles! 

 parem hiireklõps est_count peal > Zoom To Layer 

Nagu näete, on see kiht tegelikult tööfailis olemas, kuid visualiseeritud kuskile 

universumi avarustesse. 

 Tools töövahendite ribast nupp Full Extent 

Tööakna allservas olev lilla täpike ongi see koht, kuhu on paigutunud est_count kihis 

olevad lillad maakonnad. 

 Eemaldage kiht est_count 

1.2.2. Füüsiline transformeerimine 

Füüsilise transformeerimise korral muudetakse faili projektsiooni-infot, koordinaadid 

arvutatakse ümber ning salvestatakse uues koordinaatidesüsteemis. Füüsilist 

transformeerimist on teil vaja selleks, et teha ArcGIS’is ruumianalüüse. Paljud 

ArcGIS’i töövahendid nõuavad, et analüüsis osalevad andmed oleksid samas 

koordinaatide süsteemis.  

 Catalog’is vaadake kihi raudtee_bk projektsiooni-infot. 

5. Mis projektsioonis on raudtee_bk? 

6. Millise Eesti topograafilise kaardi projektsioon see on? 

Järgnevalt arvutame radtee_bk …..  projektsioonis olevad koordinaadid ümber 

Asulad1 kihi koordiaatsüsteemi. Selleks kasutame töövahendit, mis asub 

ArcToolbox'is. 

 Avage ArcToolbox aken 

 Klõpsake + märki Data Management Tools ees 

 Topeltklõps Projetions and Transformations >Feature>Project 

Dialoogiaknas määrake järgmised parameetrid: (Input – sisendkiht, Output 

Coordinate System– koordinaatide süsteem, millesse sisendkihi koordinaadid ümber 

arvutatakse, antud juhul impordime selle projektsiooni-info kihilt Asula1.shp. 

Geographic Transformation – defineeritakse, milliseid transformatsioone on vaja 

teha) 

  Input – raudtee_bk,  

7. Miks te ei saa Input kihti valida rippmenüüst, vaid peate kasutama nuppu ? 

 Output – valige oma töökataloog, kihinimeks (lahtrisse Name) pange 

raudtee_bk_Project 
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 Output Coordinat System  - Import>Asula1.shp>OK 

 OK 

 Tutvuge raudtee_bk_Project projektsiooni-infoga 

Pange tähele, et projektsiooni nimetus on metaandmetes muutunud.  

 

Mitmeid transformeerimisvahendeid võib leida ka ArcMap’i menüüdest 

1.3. Koolutamine 

Koolutamiseks peate valima oma andmekihtides (nii aktiivses projektsioonis oleval 

kihil kui ka teadmata projektsioonis oleval e. koolutataval kihil) sellised punktid, mis 

esinevad mõlemal kihil ning on selgesti samastatavad. Nimetame neid punkte 

edaspidi kinnispunktideks (kasutada võib ka mõistet "ankurpunktid"). Protsess 

seisneb selles, et kõigepealt näitate ära kinnispunkti koolutataval (antud juhul 

rasterkihil) kihil ning seejärel selle koha, kus ta "tõsta" tahate e. näitate ära 

samaväärse kinnispunkti projektsiooniga andmekihil.  

 

Need kaks punktipaari moodustavad koolutamise seose e. lingi. Linke on võimalik: 

- lisada käsitsi 

- lugeda sisse linkide failist 

- projektsiooniga andmekihi kinnispunktid (Control Points) lugeda sisse failist, 

koolutataval andmekihil näidata punktide asukoht käsitsi. 

1.3.1. Rasterandmete koolutamine 

Rasterandmete koolutamiseks kasutame käsitsi linkide lisamist.  

1.3.1.1. Andmete laadimine, töökeskkonna ettevalmistamine 

Järgnevalt püüame Saaremaad kujutava rasterfaili Maakonna ja riigimaanteede kihi 

järgi koolutada vektorfaili projektsiooni. 

 Laadige ArcMap'i riigimaanteed.shp 

 Laadige ArcMap'i saarema.tif.  Kui saaremaa avamisel küsitakse, kas soovite, et 

moodustatakse püramiidid, vastake YES (püramiidid kiirendavad selle kihiga 

töötamist) 

8. Mis tüüpi andmetega on tegu? 

Saaremaad te tööaknas ei näe, sest ta on avatud teie nägemisulatusest väljaspool.  

 Kuvage riigimaanteed Highway leppemärgiga 

Avame töövahendi Georeferencing 

 Parem hiireklõps töölaua päise hallil alal > Georeferencing 
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Selleks, et me näeksime ühes tööaknavaates korraga nii raster-, kui vektorkaarti, 

kuvame nad mõlemad ühte vaatesse 

 Suurendage tööaknasse Saaremaa ja Hiiumaa 

 

 Georeferncing >Fit To Display 

 Nupp Add Control Points  

 Avage Magnifier aken 

1.3.1.2. Koolutamise linkide lisamine 

Esmalt näitame rastril ära punkti, mida nihutatakse ning seejärel vektorkaardil 

punkti, kuhu nihutamine toimub 

 Kasutades Magnifier akent otsige rasterkaardilt iseloomulik punkt (nt. Sõrve 

sääre tipp), ning klõpsake seda hiirega 

 Seejärel leidke sama punkt vektorkaardil 

Pange tähele, et rasterkaart muudab oma asukohta koheselt, mistõttu iga järgneva 

lingi lisamine on järjest kergem (ühiste punktide leidmise mõttes) 

 Lisage sarnaselt eelnenuga veel 4 linki. Jälgige, et kõigepealt näitate punkti 

rasterkaardil ning seejärel vektorkaardil 

Juhul, kui olete juba alustanud lingi märkimist (olete märkinud ära punkti 

rasterkaardil), on teil olemas võimalus sisestada sihtpunkti koordinaadid ka käsitsi või 

lingi märkimine katkestada. 

 Märkige suvalisse kohta rasterkaardil lingi algus ning parem hiireklõps > Cancel 

Point 

 Linkide kontrollimiseks avame nupuga View Link Table linkide tabeli 
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Avanenud akna tabelis on näidatud koolutamise punktipaarid ning jääkvead, antud 

juhul meetrites. Akna alumises servas saate valida transformeerimise meetodit ning 

näete keskmist ruutviga (antud juhul jälle meetrites). Transformeerimise meetodite 

valikuvõimaluste hulk sõltub sellest, kui palju linke te olete sisestanud. Mida rohkem 

on linke, seda rohkemate meetodite vahel valida saate. 

9. Miks näidatakse viga meetrites, aga mitte näiteks mm-s?  

10. Kui suur on keskmine ruutviga? 

 Kustutage tabelist kõige suurema jääkveaga rida. 

11. Kui suur on keskmine ruutviga nüüd? Kas see suurenes või vähenes? 

1.3.1.3. Tulemuste salvestamine 

 Georeferencing > Update Georeferencing 

Kontrollime, kas meie koolutamine ikkagi õnnestus 

 Eemaldage saaremaa.tif 

 Laadige uuesti saaremaa.tif 

Kui olete teinud kõik õigesti, peaks saaremaa.tif avanema Maakonnad kihi taustal 

Saaremaa koha peal. 

 

Rasterandmete matemaatilise aluse muutmiseks on ArcGIS’il hulgaliselt ka muid 

vahendeid, mis asuvad tööriistakastis Data Management Tools > Projections and 

Transformations > Raster. Siin asuvad vahendid rasterkaartide pööramiseks ümber 

rõhttelje (Flip), pööramiseks ümber vertikaaltelje (Mirror), tranformeerimiseks 

(Project Raster), skaleerimiseks (Rescale), keeramiseks (Rotate), nihutamiseks 

(Shift), kindelpunktide järgi koolutamiseks (Warp) 

1.3.2. Vektorandmete koolutamine 

Vektorandmete koolutamiseks kasutame linkide määramiseks seda meetodit, kus 

projektsiooniga andmekihi kinnispunktid on salvestatud faili ning koolutatava 

andmekihi kinnispunktid näitame kaardil käsitsi. Fail, kuhu on salvestatud 

kinnispunktikoordinaadid, on tekstifail, kus on toodud ära punkti number, X 

koordinaat ja Y koordinaat. Andmed on üksteisest eraldatud tabulaatoriga.  

1.3.2.1. Andmete laadimine, töökeskkonna ettevalmistamine 

 Avage ArcMap’is uus tühi kaart. 

 Laadige kiht Tänavad 

 Laadige Tänava_lisa. Muutke tänava_lisa leppemärk silmatorkavamaks (lai 

punane joon näiteks) 

12. Miks te ei näe tööaknas Tänava_lisa joonist? 
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Meie ülesandeks on "tõsta" Tänav_lisa kihis olevad objektid (on digitud meile mitte 

teada olevas koordinaatide süsteemis) Tänavate kihti nii, et nende asukoht oleks õige. 

 Parem hiireklõps Tänav_lisa peal > Zoom To Layer 

Kuna koolutamise tulemused eeldavad andmekihis tehtud muudatuste füüsilist 

salvestamist faili, peame käivitama andmete toimetamise režiimi (vt. ka III osa 1. 

ptk), mille töövahendid asuvad Editor tööriistaribas. 

 

 Kui teie ekraanil selline tööriistariba puudub, siis nupp  

 Editor tööriistaribast valige Editor > Start Editing > Tänava_lisa > Continue 

 Lülitame sisse veel ühe tööriistariba.: parem hiireklõps hallil ala > Spatial 

Adjustment 

 
 

 

 

Esimese sammuna koolutamisel, defineerime ära, millist andmekihti koolutama 

hakatakse 

 Spatial Adjustment tööriistaribal klõpsake Spatial Adjustment > Set adjust Data  

 Klõpsake All Features in these layers, eemaldage linnuke kastist Tänavad > OK 

 Spatial Adjustment tööriistaribal klõpsake Spatial Adjustment > Adjustment 

Methods > Transformation – Affine 

Afiinne transformatsioon eeldab vähemalt kolme koolutuslingi olemasolu.  

 

Kuna koolutataval kihil tuleb kinnispunktid näidata käsitsi ning koolutamise täpsus 

sõltub sellest, kui täpselt me hiirega ekraanil koha lokaliseerime, siis on suurima 

võimaliku täpsuse saavutamiseks kasulik sisse lülitada snäpirežiim joone 

otspunktidesse. 

 Editor tööriistaribas Editor > Snapping > SnappingToolbar > valige nupp End 

Snapping (snäpitakse kihil Tänav_lisa olevate joonte otspunktidesse) 

1.3.2.2. Koolutamise linkide defineerimine 

Järgmisena hakkame kaardil näitama koolutamise linke. Seekord kasutame meetodit, 

kus sihtkoha (e. projektsioonis oleva kaardi) koordinaadid on meil tekstifailina 

Uus link Linkide tabel Atribuutide ülekandmise vahend 
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olemas. Esmalt loeme sisse projektsioonis kontrollpunktid ning seejärel seome iga 

punkti koolutatava kaardi mingi punktiga. 

 Spatial Adjustment > Links > Open Control Points File > Tänavad.txt > Ava 

 Muutke akna suurust ja paigutust nii, et koordinaatide aken ja kaardiaken oleksid 

samaaegselt nähtavad 

 Kinnispunktide aknas parem hiireklõps esimesel punktil >Add link 

 
 

 

 Tööaknas klõpsake jooneotsa nr 1 (vt. joonis) peale. Kuna snäpp on sisse lülitatud, 

siis ei pea te jooneotsa ülitäpselt tabama. 

 Korrake tegevust (add kinnispunkti tabelis, klõps jooneotsas kaardil) kuni kõik 

punktid on omavahel lingitud 

 Full Extend 

Tööaknas on näha, kui “kaugel” on teineteisest projektsiooniga ning koolutatav 

andmekiht ning mida kuhu nihutatakse. 

 Et täpselt näha, kuhu Tänavad_lisa paigutatakse, suurendage nooleotsa piirkond. 

Praeguse hetkeni transformeerimist veel toimunud ei ole. Enne selle juurde asumist 

peame kontrollima, kui õnnestunult me koolutuslingid oleme defineerinud. Selleks 

avame linkide tabeli, kus viimases reas näidatakse punkti jääkviga. Tabeli alumises 

vasakus nurgas näete antud linkidega tehtud transformeerimise ruutkeskmist viga. 

Mida väiksem on viga, seda õnnestunum on transformeerimine. Täpsuse 

suurendamiseks (juhul, kui teil on linke hulgaliselt), võite kustutada mõne sellise 

lingi, mille jääkviga on suurem kui teistel. 

(1) (2) 

(3) 

(4) (5) 

(6) 
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 Spatial Adjustment tööribal vajutage nuppu View Link Table 

13. Kui suur on teie linkide ruutkeskmine viga? 

 Avanenud tabelis klõpsake Residual Error veeru päist (read sorditakse vea 

kasvamise järjekorda) ning kustutage kõige suurema veaga link. 

14. Milline on RMS Error nüüd? 

 Sulgege linkide tabel 

1.3.2.3. Andmekihi koolutamine 

 Spatial Adjustment >Spatial Adjustment > Adjust 

 Editor töökastiribast Editor > Save Edits 

 Editor töökastiribast Editor > Stop Edits 

1.4. Kahe erineva kihi servade ühildamine (Edge matching) 

Tihti on nii, et mingi suurema piirkonna ruumiandmete sisestamine on jagatud mitme 

töötaja vahel. Kui asute aga kahe erineva töötaja tööd võrdlema, siis avastate, et nende 

tööpiirkondade piirialadel ei lange jooned, pinnad kokku. Samuti võivad nihked tulla, 

kui andmeid on transformeeritud ühest koordinaatide süsteemist teise. 

1.4.1. Geomeetria ühildamine 

 Avage uus tühi kaart 

15. Mis nuppu selleks kasutasite? Millist menüü käsku selleks kasutada saab? 

 laadige kihid oja_ida, oja_lääs 

 Muutke leppemärke nii, et kihid oleksid eristuvad 
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Nagu näete, on piirialal kõik ojad kas nihkes, ei ulatu teineteiseni või kattuvad 

 Alustage toimetamise sessiooni Editor > Start Editing 

 Lülitage sisse joone otsa snäppimise režiim Snapping Toolbr > END 

 Spatial Adjustment tööriistaribas Spatial Adjustment > Set Adjust Data > 

oja_lääs 

 Spatial Adjustment > Adjustment Methods > Edge Snap 

Edge Snap’i on võimalik teha kahel meetodil: Line ja Smooth. Line meetodi puhul 

ühendatakse joonte lähimad verteksid (käänupunktid) omavahel sirgjooneliselt. 

Smooth meetodi puhul leitakse ühenduspunktidele keskmine. 

 Spatial Adjustment > Options > General > Options > Line > OK > OK 

 Menüüst Window > Magnifier > parameeter 800% 

 Spatial Adjustment tööriistaribas nupule New Displacement Link 

 Suurendusaknas klõpsake kõigepealt selle joone otsa, mida hakatakse nihutama 

ning seejärel selle joone otsa, kuhu nihutatakse. 

16. Mis kiht on seega esimene, millele klõpsate, mis teine? 
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 Korrake tegevust kuni kõik jooneotsad on seotud e. lingitud. 

 Spatial Adjustment > Adjust 

 Uurige suurendusaknaga tulemust. 

Nagu näete, on tulemus üpriski ebaloomulik, kui mõelda, et tegemist on looduslike 

ojadega. Oletada võib, et selliseid hüppeid looduslik oja ei tee. Seega ojade 

ühtlustamiseks Line meetod meile ei sobi. 

 Menüüst Edit > Undo või kiirklahv Ctrl+Z 

 Spatial Adjustment > Options > General > Options > Smooth > OK > OK 

 Spatial Adjustment > Adjust 

 Uurige suurendusaknaga tulemust. 

1.4.2. Tärkandmete ühtlustamine 

Lisaks sellel, et jooneotsad ei saa piiril omavahel kokku, on sage ka selline olukord, 

kus piiril muutub objekti mingi atribuut. Ühel kaardilehel on pinnastee, teisel 

kaardlehel jätkub joon edasi hoopiski rajana.  

Järgnevaks üleandeks on viia omavahel kooskõlla ka atribuutandmed. Eeldame, et 

atribuudid oja_ida kihis on õiged. 

 Tutvuge oja_ida ja oja_lääs atribuutide tabelitega 

 Parem hiireklõps oja_ida nimel > Open Attribute Table, sama oja_lääs kihiga 

 
 

Mõlemad tabelid avatakse ühes aknas. Kui soovite vaadata tabeleid kordamööda, 

valige akna alumisest ribast vastav sakk. Kui soovite aknas vaadata korraga mitut 

tabelit, haarake hiirega mitteaktiivsest sakist ning lohistage tööaknasse ilmunud 

kompassi ühele sakile. Joonisel olevas näidises paigutatakse oja_ida atribuutide tabel 

sinisega varjutatud alasse. 
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17. Milles seisneb tabelite erinevus? 

 Editor tööriistaribast Snapping Toolbr > sisse Edge, välja End  

Pange tähele, et kihid kasutavad atribuutidel erinevaid väljanimesid – kaks väljanime 

on sarnased, üks erinev. Ühtlustame tabelite väljanimed. 

 Spatial Adjustment > Attribute Transfer Mapping 

 Source Layer oja_ida, Target Layer oja_lääs 

 Klõpsake AutoMatch, samanimelised väljad ilmuvad Matched Fields aknasse 

 Valige järgi jäänud Name ja Stream Name. Klõpsake Add. Seda operatsiooni 

võite kasutada vaid juhul, kui andmed on SISULISELT tõepoolest samased. 

 Linnuke välja kastist Transfer Geometry, sulgege aknen >OK 

 Sulgege oja_ida atribuutide tabel. Muutke oja_lääs atribuutide tabeli akna suurust 

nii, et teil oleksid paralleelselt nähtavad nii ojade kaart kui tabel. Nii saate 

koheselt jälgida, kuidas muutuvad atribuutide väärtused teie toimetamise käigus. 

Lisame atribuudid graafilises keskkonnas nii, et kõigepealt näitame, milliselt joonelt 

atribuudid võetakse ning seejärel joonele, millele me atribuute omistada tahame. 

 Spatial Adjustment tööriistaribal klõpsake nuppu Attribute Transferse Tool 

 Klõpsake oja-ida kihi joonele ning seejärel oja_lääs kihi joonele 

 Omistage atribuudid kahele ülejäänud joonele 

 Salvestage muudatused, peatage Edit režiim, sulgege ArcMap  

1.5. Projektsiooni info lisamine või muutmine kasutades 
Pythonit 

Projektsiooni defineerimiseks või muutmiseks on võimalik kasutada ka Pythoni 

tööakent ja käsklust DefineProjection_management (in_dataset, coor_system), 

kus: 

in_dataset sümboliseerib objektiklassi või andmekihti, mille projektsiooni 

defineeritakse ja  

coor_system tähistab projektsiooni-infot sisaldavat *.prj laiendiga mallifaili. 

Kasutatakse kui projektsiooni-infot pole lisatud või olemasolev info on vale. 

 

Lisame projektsiooni-info andmekihile kool. Ühtlasi kontrollime kasutusel olevat 

töökataloogi. Täpsemat informatsiooni erinevate koordinaatsüsteemide ja nende 

koodide kohta leiab ArcGISi dokumentatsioonikataloogist (C:\Program Files 

(x86)\ArcGIS\Desktop10.5\Documentation). 

 

 Avage ArcMap 
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 Avage Pythoni tööaken 

 

18. Kuidas avada Pythoni tööakent? 

 Kontrollida töökataloogi asukohta. Vajadusel seda muutes. 

19. Kuidas kontrollida ja muuta töökataloogi asukohta? 

 Sakk Catalog. Tehke koopia kihist kool. 

 Sisestage Pythoni tööaknasse järgnev skript. 

 

 Kontrollige kihihaldurisse ilmunud kihi omadusi. 

20. Mis projektsioon on kihil kool? 

Tihtipeale on lihtsam koordinaatinfo importida teiselt olemasolevalt kihilt. Teeme 

seda kopeeritud kihi koolCopy näitel. Kasutatud on try-except käsklust, mis on 

kasulik koodist vigade otsimisel. Kui viga ilmneb skripti try osas liigutakse edasi 

erandite juurde. ExecuteErrori osa näol on tegu tööriista sisese veateatega.  

 Sisestage Pythoni tööaknasse järgnev skript. 
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2. Päringutega töötamine 

2.1. Konkreetse objekti leidmine 

Kaardilt konkreetse objekti leidmiseks kasutatakse Find tööriista 

 Avage eelmises praktikumis tehtud Harjutus1.mxd 

Eelmises osas kehtestasime jõgedele kuvamispiirangu. Tühistame selle. 

 topelt hiireklõps kihil jõed > Properties > Definition Query > kustutage aknas 

olev päring > OK  

 Tools töökastiribas valige Find nupp  

 

 

Leiame üles Preedi jõe 

 Sakk Features, Find > Preedi >Find.  

Soovi korral võite täpsustada ka, millisest kihist ja veerust otsitakse: 

  in > jõed (kiht, kust otsitakse), Search > In Field NIMI >Find 

 Parem hiireklõps otsingutulemuse reale  > Zoom To 

Hiirega otsingutulemuse reale klõpsates välgutatakse objekti tööaknas. 

 Uurige, mida pakuvad teile teised hüpikmenüüs olevad töövahendid Flash, Select, 

Unselct 

ArcMap võimaldab sättida ka bookmark’e e. järjehoidjad, mis salvestatakse ka *.mxd 

faili. Järjehoidjad on eriti kasulikud siis, kui on vaja korduvalt mingit konkreetset 

kohta üles leida 

 Parem hiireklõps otsingutulemuse reale > Create Bookmark 

 Sulgege dialoogiaken 

 Tools tööriistakastist Full Extent 

 Menüüst Bookmarks > Preedi 

Kui te ei leia töökastiribast 

soovitud nuppu, siis vajutage riba 

lõpus olevale noolekesele 
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2.2. Ruumipäringu tegemine 

2.2.1. Päringu defineerimine 

Järgmisena teeme ruumipäringu, mille käigus leiame kõik linnad, mis jäävad raudteest 

mitte kaugemale kui 1 km 

 Tools tööriistakastist Full Extent 

 Menüüst Selection > Select by Location 

 Selection method (valiku meetod):  select features from,  

 Target layer (kiht, kust valitakse objektid): linnukesed ASULA1, ASULA2,  

 Source layer (kiht, mille alusel päring tehakse) raudtee: 

 Spatial selection method (ruumipäringu liik) : …are within a distance of…., 

 linnuke Apply a search distance > 1 > Kilometers > OK 

Otsingu tulemusena värvitakse tingimustele vastavad linnad tööaknas helesiniseks. 

 

Ruumipäringu liikide kohta lugege lähemalt: help > search > select by location.  

Sellel lehel on ruumipäringute erinevad ligid (are within, interct jne) selgitatud 

jooniste abil. 

 

Järgmisena uurime päringutulemusi atribuutide tabelites. 

 Avage kihti ASULA1 atribuutide tabel: parem hiireklõps ASULA1 > Open 

Attribute Table 

  Tehke sama ASULA2 -ga  

21. Mitu rida on valitud tabelist ASULA2, mitu tabelist ASULA1? 

 Vajutage tabelite allservas olevat nuppu Selected 

Loendisse kuvatakse vaid need read, mis olid ruumipäringuga välja valitud. 

2.2.2. Päringu tulemuse salvestamine eraldi kihiks 

 Parem hiireklõps kihil ASULA2 > Selection > Create Layer From Selected 

Features 

Kihihaldurisse ilmub uus kiht ASULA2selection 

 Nimetage kiht ümber – raudteelinn 

Valitud objektidest saate ArcMap’is moodustada uue kihi, kuid see kiht eksisteerib 

vaid näiliselt. Salvestatud objektidest ei moodustata uut, raudteelinn nimelist shape 

faili või objektiklassi. Tegelikult salvestatakse kaardidokumenti päring ning 

kuvatakse tulemus teie poolt soovitud (defineeritud) viisil. 
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Kontrollime eespool toodud väidet. 

 Avage raudteelinn kihi Layer Properties > Source  

22. Mis failist selle kihi andmed võetakse? 

 Sulgege dialoogiaken 

 Tühistage valik Tools tööriistaribast nupuga Clear Selected Features  

Kui soovite teha päringutulemusest eraldi faili, peate kihi eksportima: parem 

hiireklõps raudteelinn > Data > Export Data 

2.3. Atribuutpäringu tegemine 

Meie ülesandeks on koolide kihist välja eristada maagümnaasiumid. 

Seda teeme kahe päringu kaudu. Esmalt otsime atribuutpäringuga välja kõik koolid, 

mille tüübiks on gümnaasium ning seejärel ruumipäringuga eemaldame valikust kõik 

koolid, mis jäävad meie kaardil kujutatud linnadesse. 

 Laadige ArcMap'i kiht kool.shp 

 Menüüst Selection > Select by Attributes 

 Layer: kool, Method: Create a new selection 

Järgmisena koostame päringuaknasse päringu, mille järgi valitakse välja kõik koolid, 

mis on gümnaasiumid 

 Aktiviseerime päringuakna. Topeltklõps väljanimele “TYYP”, nupp = , nupp Get 

Unique Values, tekkinud loendist topeltklõps ‘Gümnaasium’, kontrollime 

päringu süntaksi nupuga Verify, kui kõik on korras, käivitame päringu nupuga 

OK. 

23. Mitu kooli on valimis? 

2.4. Atribuut- ja ruumipäringu ühendamine 

Järgmise ülesandena peame valitud gümnaasiumitest alles jätma need koolid, mis 

asuvad väljaspool ASULA1 ja ASULA2 olevaid linnasid. Kuna kasutame päringu 

tegemiseks teisi kihte, on tegemist ruumipäringuga. Otsime gümnaasiume, mis 

ASLUA1 linnadest asuvad kaugemal, kui 10 km ning ASULA2 linnadest kaugemal, 

kui 5 km. 

 Menüüst Selection > Select by Location 

 remove from the currently selected features in; Target layer: kool (NB! ärge 

unustage linnukesi eemaldada Asula1 ja Asula2 eest, me ei vali asulaid); Source 

layer: ASULA1; Spatial selection method: ….are within distance….;; Applay a 

search distance: 10 km > Apply 

 Korrake sama tegevust, kuid nüüd kihiga ASULA2, otsimiskauguseks 5 km 
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 Vaadake kool andmetabelit. Kontrollige, ega ei ole juhuslikult jäänud andmete 

hulka mõnda suurlinna kooli. Vihje : kasutage nuppu Selected 

Nüüd salvestame päringu tulemuse eraldi SHP faili nimega maakool 

 Parem hiireklõps kihil kool > Data > Export Data 

 Export: Selected features, Use the same coordinate system as: the data 

frame¸Output shapefile or feature class:  sisestage oma töökataloog; Save as 

type: shapefile > Save > OK – EI/NO 

 Salvestage kaardidokument ArcGIS/Tulemused/Harjutus2.mdx failina: Fail > 

Save AS > ….. 

 Sulgege ArcMap 

2.5. Päringute tegemine kasutades Pythoni tööakent 

2.5.1. Ruumipäring 

Ruumipäringute tegemiseks on olemas käsklus: 

SelectLayerByLocation_management (in_layer, {overlap_type}, 

{select_features}, {search_distance}, {selection_type}, 

{invert_spatial_relationship}).  

 

Olulisemad parameetrid on  

overlap_type, mis määrab analüüsitava ruumilise suhte,  

select_features näitab ära, millise andmekihi suhtes sisendkihist objekte valitakse, 

selection_type defineerib valiku tüübi (vaikimisi New Selection)  

invert_spatial_relationship defineerib, kas valitakse tulemus või selle vastand. 

Täpsemalt vt ArcGIS Help. 

 

Järgnevalt valime ruumipäringuga välja linnakoolid. 

 Ava ArcMap 

 Ava Pythoni tööaken 

 Impordi ArcPy ja kontrolli töökataloogi, vajadusel seda muutes 

 Sisestage alljärgnev skript 
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2.5.2. Atribuudipäring 

Atribuutpäringute tegemiseks on olemas käsklus 

SelectLayerByAttribute_management (in_layer_or_view, {selection_type}, 

{where_clause}), kus  

in_layer_or_view viitab andmekihile või tabelile, mille suhtes valikut rakendatakse ja 

where_clause – SQL päring, mis määrab valiku tingimuse(d). 

 

Kasutame atribuutpäringut tuvastamaks valitud linnakoolidest ainult venekeelseid 

linnagümnaasiume ja salvestame need uuele kihile. 

 

 Sisestage alljärgnev skript 

 
 

24. Mitu venekeelset linnagümnaasiumit tuvastati? 

 Sulgege ArcMap 

3. Andmete importimine geoandmebaasi 

3.1. CAD failist importimine 

CAD failidena käsitleme selles kursuses DGN faile. Kuid siia alla kuuluvad veel 

näiteks ka DXF ja DWG failid. 

 

Esimesena viime Teemad geoandmebaasi epiir.dgn andmestiku 

 Avage Catalog, liikuge oma töökataloogi. 

 Klõpsake + märki epiir nime ees.  

 Avage Polyline ojektiklassi Porperties. > sakk XY Coordinate System 

Pange tähele, et sellele kihile pole lisatud projektsiooni infot. 

 Sulgege aken nupuga Cancel 

 CAD andmete eksportimiseks parem hiireklõps Polyline kihinimel > Export > To 

Geodatabase (single) 

 Output Location: Teemad.mdb; Output Feature Class (annate geoandmebaasis 

objektiklassile nime) > riigipiir; Field Map (loetelust saate kas lisada või 

eemaldada need atribuudiväljad, mida te geoandmebaasi exportida soovite/ei 
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soovi või muuta veergude järjekorda): eemaldame kõik Qrot’iga algavad väljad 

(valige väli ning vajutage paremal olevale ristiga nupule) > OK 

 

 Klõpsake Teemad.mdb nimele. Contents vaates peaks olema teil näha, et 

geoandmebaasi on tekkinud uus objektiklass riigipiir 

 Lisage kihile Eesti põhikaardi projektsiooni-info: Properties >XY Coordinate 

System > Select > Projected … > National Grids > Estonia 1997 Estonia 

National Grid.prj > OK 

3.2. DBF tabeli importimine 

Impordime Maakonnad_2007.dbf andmetabeli geoandmebaasi 

 Catalog'is parem hiirklõps Teemad.mdb nimel > Import > Table (Single) 

 Input Rows: Maakond_2007.dbf; Output Table (tabeli nimi geoandmebaasis) 

MK_vanuserühmad >OK 

Sama tegevust on teil võimalik teha ka kasutades ArcToolbox’i töövahendit 

Conversion Tools > To Geodatabase > Table to Tabel 

25. Millised oleksid olemasolevasse tabelisse uue välja juurde tegemise 2 võimalust? 

3.3. SHP faili importimine 

3.3.1. Shape-faili konverteerimine Conversion Tools abil 

Selleks, et teha andmeanalüüse (näiteks topoloogiakontrolli), on tarvis analüüsi 

tegemiseks andmeid konverteerida vajalikku andmeformaati (näiteks geoandmebaasi). 

ArcGIS-is on mitmeid konverteerimise võimalusi. Antud harjutuses kasutame 

ArcToolbox vahendit, millega konverteerime SHP faili geoandmebaasi 

objektiklassiks. Meie ülesandeks on lisada raudteed geoandmebaasi Teemad 

 

Kõigepealt loome oma andmebaasi uue raamobjekti Transport, millele defineerime 

eesti põhikaardi projektsiooni. 

 Catalog'is parem hiireklõps Teemad.mdb > New > Feature Dataset > 

Transport > Next > Import > raudtee.shp > Add > Next > Next > Finish 
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 Standardtööribal klõpsake nuppu Show/Hide ArcToolbox Window  

Kataloogipuu ning tööakna vahel avaneb uus, ArcToolbox aken 

 ArcToolbox > Conversion Tools; > To Geodatabase > Feature Class to 

Feature Class 

 Input Feature Class  raudtee.shp>Add 

 Output Location : topeltklõps Teemad >Transport >Add 

 Output Feature Class Name (anname geoandmebaasis objektiklassile nime) – 

tippige raudteed 

 Sulgege dialoogiaken OK 

 Kataloogipuus kontrollige, kas Teemad geoandmebaasi tekkis uus, raudteed 

nimeline, objektiklass. Juhul kui ei tekkinud, tehke parem hiireklõps Teemad 

peal, valige hüpikmenüüst Refresh. 

3.3.2. Shape-faili import käsuga 

Järgmiseks kasutame meile tuttavatkataloogipuu hüpikmenüüst käsk Import. 

Laadimiseks kasutame maakoolid.shp faili. 

 Tuletage meelde maakool.shp fali sisu ja struktuur. 

 Catalogis parem hiireklõps Teemad.mdb > Import > Feature Class (single) 

 Täitke kohustuslikud read, Output Feature Class nimeks pange maagümnaasium 

> OK 

 Kontrollige tulemust teemad.mdb-s 

Pange tähele, et antud juhul konverteeritakse shp-fail geoandmebaasi ISESEISVAKS 

objektiklassiks, mitte aga raamobjekti kuuluvaks objektiklassiks. 

3.3.3. Shape-faili konverteerimine Simple Data Loader abil 

Simple Data Loader'it kasutame siis, kui me ei taha luua uut andmeobjekti vaid lisada 

andmeid olemasolevale.  

 

Esimese sammuna loome raamobjekti Transport alla uue, tühja, objektiklassi riigiteed, 

mille struktuur vastaks üks-ühele kiirteed.shp andmetabeli struktuurile. Selleks 

impordime tabeli struktuuri (mitte andmed) kiirteed.shp kihist. 

 Parem hiireklõps Transport > New > Feature Class 

 Name: riigiteed, Type: Line Features > Next 

 Import > kiirteed.shp > Add > Finish 
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Impordime sellesse tabelisse riigimaanteed.shp ning kiirteed.shp failides olevad 

andmed.  

 Parem hiireklõps riigiteed nimel > Load > Load Data > Next 

 Input Data: topeltklõps nimel kiirteed.shp > Add,  uuesti Input Data: topeltklõps 

nimel riigimaanteed.shp > Add > Next > Next > Next > valige Load all of the 

source data > Next > Finish 

26. Kuidas on võimalik ilma kaardikihti ArcMap'i laadimata näha Teemade 

andmebaasis olevate riigiteede kujutist ehk kontrollida visuaalselt, kas kihis on 

olemas nii kiir- kui muud riigiteed? 

 Sulgege ArcMap 

3.4. Andmete importimine kasutades Pythoni tööakent 

3.4.1. DBF tabeli importimine 

DBF tabeli importimiseks geoandmebaasi Pythoni tööaknas on käsklus 

TableToTable_conversion (in_rows, out_path, out_name, {where_clause}, 

{field_mapping}, {config_keyword}).  

Kasutame antud käsklust Maakonnad_2007 tabeli importimiseks Teemad 

geoandmebaasi. Parameetrite kohta leiab täiendavat informatsiooni ArcGISi Helpist 

 Avage ArcMap 

 Avage Pythoni tööaken. Importige ArcPy ja kontrollige töökataloogi asukohta. 

Vajadusel seda muutes 

 Sisestage järgnev skript 

 

 Kustutage geoandmebaasist imporditud objektiklass 

3.4.2. SHP-faili importimine 

SHP-faili importimiseks kasutatakse käsklust 

FeatureClassToFeatureClass_conversion (in_features, out_path, out_name, 

{where_clause}, {field_mapping}, config_keyword).  

 

Kasutame antud tööriista venekeelsete linnagümnaasiumite importimiseks 

geoandmebaasi. 

 Sisestage järgnev skript 

 
 


